about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorSpencer Whitt <sw@swhitt.me>2015-05-22 20:08:22 -0400
committerSpencer Whitt <sw@swhitt.me>2015-05-22 20:11:09 -0400
commitffcea6546d4832d5141add56f1d6126a6fd33a5e (patch)
tree67c154e95a8de9a21fcc97a59a50f42779217af2 /pkgs/development
parent3d60104a74fa72e1fc00ed17684b134655479861 (diff)
downloadnixlib-ffcea6546d4832d5141add56f1d6126a6fd33a5e.tar
nixlib-ffcea6546d4832d5141add56f1d6126a6fd33a5e.tar.gz
nixlib-ffcea6546d4832d5141add56f1d6126a6fd33a5e.tar.bz2
nixlib-ffcea6546d4832d5141add56f1d6126a6fd33a5e.tar.lz
nixlib-ffcea6546d4832d5141add56f1d6126a6fd33a5e.tar.xz
nixlib-ffcea6546d4832d5141add56f1d6126a6fd33a5e.tar.zst
nixlib-ffcea6546d4832d5141add56f1d6126a6fd33a5e.zip
gtk3: fix on Darwin
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/libraries/gtk+/3.x.nix9
1 files changed, 5 insertions, 4 deletions
diff --git a/pkgs/development/libraries/gtk+/3.x.nix b/pkgs/development/libraries/gtk+/3.x.nix
index 18aaa9fa2282..252e52ee3b98 100644
--- a/pkgs/development/libraries/gtk+/3.x.nix
+++ b/pkgs/development/libraries/gtk+/3.x.nix
@@ -25,12 +25,13 @@ stdenv.mkDerivation rec {
 
   buildInputs = [ libxkbcommon epoxy ];
   propagatedBuildInputs = with xlibs; with stdenv.lib;
-    [ expat glib cairo pango gdk_pixbuf atk at_spi2_atk ]
-    ++ optionals stdenv.isLinux [ libXrandr libXrender libXcomposite libXi libXcursor wayland ]
-    ++ optional stdenv.isDarwin x11
+    [ expat glib cairo pango gdk_pixbuf atk at_spi2_atk libXrandr libXrender libXcomposite libXi libXcursor ]
+    ++ optionals stdenv.isLinux [ wayland ]
     ++ optional xineramaSupport libXinerama
     ++ optional cupsSupport cups;
 
+  NIX_LDFLAGS = if stdenv.isDarwin then "-lintl" else null;
+
   # demos fail to install, no idea where's the problem
   preConfigure = "sed '/^SRC_SUBDIRS /s/demos//' -i Makefile.in";
 
@@ -64,6 +65,6 @@ stdenv.mkDerivation rec {
     license = stdenv.lib.licenses.lgpl2Plus;
 
     maintainers = with stdenv.lib.maintainers; [ urkud raskin vcunat lethalman ];
-    platforms = stdenv.lib.platforms.linux; # Temporary until fixed for darwin
+    platforms = stdenv.lib.platforms.all;
   };
 }