about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorJohannes Bornhold <johannes@bornhold.name>2016-12-27 08:45:37 +0100
committerJohannes Bornhold <johannes@bornhold.name>2016-12-27 14:19:26 +0100
commitfebab15b01fc2ed68e688e3819941a2c62091d8a (patch)
tree4db195e81cc73e690480da7b1ec9b709e9655e3b /pkgs/development
parent346c1db2ac336e15f2c0019292963a9c5ba37f58 (diff)
downloadnixlib-febab15b01fc2ed68e688e3819941a2c62091d8a.tar
nixlib-febab15b01fc2ed68e688e3819941a2c62091d8a.tar.gz
nixlib-febab15b01fc2ed68e688e3819941a2c62091d8a.tar.bz2
nixlib-febab15b01fc2ed68e688e3819941a2c62091d8a.tar.lz
nixlib-febab15b01fc2ed68e688e3819941a2c62091d8a.tar.xz
nixlib-febab15b01fc2ed68e688e3819941a2c62091d8a.tar.zst
nixlib-febab15b01fc2ed68e688e3819941a2c62091d8a.zip
gtk2: Enable xinput for Darwin
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/libraries/gtk+/2.x.nix10
1 files changed, 7 insertions, 3 deletions
diff --git a/pkgs/development/libraries/gtk+/2.x.nix b/pkgs/development/libraries/gtk+/2.x.nix
index 91407e556c05..ba12b4eea93b 100644
--- a/pkgs/development/libraries/gtk+/2.x.nix
+++ b/pkgs/development/libraries/gtk+/2.x.nix
@@ -38,9 +38,13 @@ stdenv.mkDerivation rec {
     ++ optional xineramaSupport libXinerama
     ++ optionals cupsSupport [ cups ];
 
-  configureFlags = if stdenv.isDarwin
-    then "--disable-glibtest --disable-introspection --disable-visibility"
-    else "--with-xinput=yes";
+  configureFlags = [
+    "--with-xinput=yes"
+  ] ++ stdenv.lib.optionals stdenv.isDarwin [
+    "--disable-glibtest"
+    "--disable-introspection"
+    "--disable-visibility"
+  ];
 
   postInstall = ''
     moveToOutput share/gtk-2.0/demo "$devdoc"