about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorArseniy Seroka <jagajaga@users.noreply.github.com>2015-07-28 00:45:19 +0300
committerArseniy Seroka <jagajaga@users.noreply.github.com>2015-07-28 00:45:19 +0300
commitfe0809fb66a161fd6e9fc6ee795ef512fa007566 (patch)
tree8970f00a20d0940d595403560b3862e7b861b12d /pkgs/development
parentcb78f09038660ca98a3107b530cbd8c90a088735 (diff)
parent6f1b2e7de2e631cddeb446736dd72771246629ef (diff)
downloadnixlib-fe0809fb66a161fd6e9fc6ee795ef512fa007566.tar
nixlib-fe0809fb66a161fd6e9fc6ee795ef512fa007566.tar.gz
nixlib-fe0809fb66a161fd6e9fc6ee795ef512fa007566.tar.bz2
nixlib-fe0809fb66a161fd6e9fc6ee795ef512fa007566.tar.lz
nixlib-fe0809fb66a161fd6e9fc6ee795ef512fa007566.tar.xz
nixlib-fe0809fb66a161fd6e9fc6ee795ef512fa007566.tar.zst
nixlib-fe0809fb66a161fd6e9fc6ee795ef512fa007566.zip
Merge pull request #9015 from AndersonTorres/lightning
Lightning: 2.0.5 -> 2.1.0
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/libraries/lightning/default.nix16
1 files changed, 9 insertions, 7 deletions
diff --git a/pkgs/development/libraries/lightning/default.nix b/pkgs/development/libraries/lightning/default.nix
index 036d9c61d07a..3805e8c1ce84 100644
--- a/pkgs/development/libraries/lightning/default.nix
+++ b/pkgs/development/libraries/lightning/default.nix
@@ -1,14 +1,17 @@
-{ fetchurl, stdenv, binutils }:
+{ stdenv, fetchurl, binutils }:
 
+with stdenv.lib;
 stdenv.mkDerivation rec {
-  name = "lightning-2.0.5";
+
+  name = "lightning-${version}";
+  version = "2.1.0";
 
   src = fetchurl {
     url = "mirror://gnu/lightning/${name}.tar.gz";
-    sha256 = "0jm9a8ddxc1v9hyzyv4ybg37fjac2yjqv1hkd262wxzqms36mdk5";
+    sha256 = "19j9nwl88k660045s40cbz5zrl1wpd2mcxnnc8qqnnaj311a58qz";
   };
 
-  # Needs libopcodes.so  from binutils for 'make check'
+  # Needs libopcodes.so from binutils for 'make check'
   buildInputs = [ binutils ];
 
   doCheck = true;
@@ -16,7 +19,6 @@ stdenv.mkDerivation rec {
   meta = {
     homepage = http://www.gnu.org/software/lightning/;
     description = "Run-time code generation library";
-
     longDescription = ''
       GNU lightning is a library that generates assembly language code
       at run-time; it is very fast, making it ideal for Just-In-Time
@@ -24,7 +26,7 @@ stdenv.mkDerivation rec {
       to the clients a standardized RISC instruction set inspired by
       the MIPS and SPARC chips.
     '';
-
-    license = stdenv.lib.licenses.lgpl3Plus;
+    maintainers = [ maintainers.AndersonTorres ];
+    license = licenses.lgpl3Plus;
   };
 }