about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorMario Rodas <marsam@users.noreply.github.com>2020-01-31 20:38:55 -0500
committerGitHub <noreply@github.com>2020-01-31 20:38:55 -0500
commitfb6d39cbde424ba4add656cdc0e1bc70ee353ad0 (patch)
tree8f36cbeb1dde0f6e98ad1646e5abedf781a90c95 /pkgs/development
parente39ecb09b7b4dd757352caab8ecc0be772f6eaf0 (diff)
parenteaea88814f2a68c3205029a889d501d3323acfc2 (diff)
downloadnixlib-fb6d39cbde424ba4add656cdc0e1bc70ee353ad0.tar
nixlib-fb6d39cbde424ba4add656cdc0e1bc70ee353ad0.tar.gz
nixlib-fb6d39cbde424ba4add656cdc0e1bc70ee353ad0.tar.bz2
nixlib-fb6d39cbde424ba4add656cdc0e1bc70ee353ad0.tar.lz
nixlib-fb6d39cbde424ba4add656cdc0e1bc70ee353ad0.tar.xz
nixlib-fb6d39cbde424ba4add656cdc0e1bc70ee353ad0.tar.zst
nixlib-fb6d39cbde424ba4add656cdc0e1bc70ee353ad0.zip
Merge pull request #78970 from zowoq/buildah
buildah: 1.13.1 -> 1.13.2
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/tools/buildah/default.nix4
-rw-r--r--pkgs/development/tools/buildah/disable-go-module-mode.patch11
2 files changed, 7 insertions, 8 deletions
diff --git a/pkgs/development/tools/buildah/default.nix b/pkgs/development/tools/buildah/default.nix
index 7a17d3dfb568..2711dafa6892 100644
--- a/pkgs/development/tools/buildah/default.nix
+++ b/pkgs/development/tools/buildah/default.nix
@@ -4,13 +4,13 @@
 
 buildGoPackage rec {
   pname = "buildah";
-  version = "1.13.1";
+  version = "1.13.2";
 
   src = fetchFromGitHub {
     owner  = "containers";
     repo   = "buildah";
     rev    = "v${version}";
-    sha256 = "0swhpdr970ik6fhvmj45r84lsp1n6rxm0bgv9i1lvrxy1mdv7r9x";
+    sha256 = "0860ynv93gbicpczfapvrd558dzbqicy9rv4ivyjhb6yyfgy4qai";
   };
 
   outputs = [ "bin" "man" "out" ];
diff --git a/pkgs/development/tools/buildah/disable-go-module-mode.patch b/pkgs/development/tools/buildah/disable-go-module-mode.patch
index a6f211412ea1..86ca9132529f 100644
--- a/pkgs/development/tools/buildah/disable-go-module-mode.patch
+++ b/pkgs/development/tools/buildah/disable-go-module-mode.patch
@@ -12,22 +12,21 @@ buildGoPackage may lead to inconsistencies.
  1 file changed, 5 deletions(-)
 
 diff --git a/Makefile b/Makefile
-index 9d04177d..4cf9b6a2 100644
+index 07724ce4..6383646e 100644
 --- a/Makefile
 +++ b/Makefile
-@@ -15,12 +15,7 @@ BUILDAH := buildah
+@@ -15,14 +15,8 @@ BUILDAH := buildah
  GO := go
  GO110 := 1.10
  GOVERSION := $(findstring $(GO110),$(shell go version))
 -# test for go module support
 -ifeq ($(shell go help mod >/dev/null 2>&1 && echo true), true)
 -export GO_BUILD=GO111MODULE=on $(GO) build -mod=vendor
+-export GO_TEST=GO111MODULE=on $(GO) test -mod=vendor
 -else
  export GO_BUILD=$(GO) build
+ export GO_TEST=$(GO) test
 -endif
- 
+
  GIT_COMMIT ?= $(if $(shell git rev-parse --short HEAD),$(shell git rev-parse --short HEAD),$(error "git failed"))
  SOURCE_DATE_EPOCH ?= $(if $(shell date +%s),$(shell date +%s),$(error "date failed"))
--- 
-2.24.0
-