about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorChris Ostrouchov <chris.ostrouchov@gmail.com>2018-08-10 16:45:38 -0400
committerChris Ostrouchov <chris.ostrouchov@gmail.com>2018-08-10 16:49:06 -0400
commitfb40e62657337f254dcf28157765d86cb60e2183 (patch)
tree42cb2c16d89a962bca091d40519b486561fb5be7 /pkgs/development
parentff27546351e00f62dd21d0334a0df2279160d084 (diff)
downloadnixlib-fb40e62657337f254dcf28157765d86cb60e2183.tar
nixlib-fb40e62657337f254dcf28157765d86cb60e2183.tar.gz
nixlib-fb40e62657337f254dcf28157765d86cb60e2183.tar.bz2
nixlib-fb40e62657337f254dcf28157765d86cb60e2183.tar.lz
nixlib-fb40e62657337f254dcf28157765d86cb60e2183.tar.xz
nixlib-fb40e62657337f254dcf28157765d86cb60e2183.tar.zst
nixlib-fb40e62657337f254dcf28157765d86cb60e2183.zip
pythonPackages.pymatgen-lammps: init at 0.4.5
 - all tests pass
 - python 3+
 - fetchurl since package is on gitlab
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/python-modules/pymatgen-lammps/default.nix31
1 files changed, 31 insertions, 0 deletions
diff --git a/pkgs/development/python-modules/pymatgen-lammps/default.nix b/pkgs/development/python-modules/pymatgen-lammps/default.nix
new file mode 100644
index 000000000000..dbe9107c7c83
--- /dev/null
+++ b/pkgs/development/python-modules/pymatgen-lammps/default.nix
@@ -0,0 +1,31 @@
+{ lib
+, fetchurl
+, buildPythonPackage
+, pymatgen
+, lammps
+, pytestrunner
+, pytest
+, isPy3k
+}:
+
+buildPythonPackage rec {
+  pname = "pymatgen-lammps";
+  version = "0.4.5";
+  disabled = (!isPy3k);
+
+  src = fetchurl {
+     url = "https://gitlab.com/costrouc/${pname}/-/archive/v${version}/${pname}-v${version}.tar.gz";
+     sha256 = "0shldl8is3195jmji7dr3zsh1bzxlahaqrmpr28niks7nnfj80fx";
+  };
+
+  buildInputs = [ pytestrunner ];
+  checkInputs = [ pytest ];
+  propagatedBuildInputs = [ pymatgen ];
+
+  meta = {
+    description = "A LAMMPS wrapper using pymatgen";
+    homepage = https://gitlab.com/costrouc/pymatgen-lammps;
+    license = lib.licenses.mit;
+    maintainers = with lib.maintainers; [ costrouc ];
+  };
+}