about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorPeter Simons <simons@cryp.to>2020-02-21 12:02:00 +0100
committerPeter Simons <simons@cryp.to>2020-02-28 20:31:26 +0100
commitf95d327f4e00792b8e6806b03ec6d294f181c2f4 (patch)
tree22faf9d24eda1eaf0aa2acdbc80170c469dc2c86 /pkgs/development
parent93b4f52f2c59a8c03bd6d12a5cfa77d82b1d4a35 (diff)
downloadnixlib-f95d327f4e00792b8e6806b03ec6d294f181c2f4.tar
nixlib-f95d327f4e00792b8e6806b03ec6d294f181c2f4.tar.gz
nixlib-f95d327f4e00792b8e6806b03ec6d294f181c2f4.tar.bz2
nixlib-f95d327f4e00792b8e6806b03ec6d294f181c2f4.tar.lz
nixlib-f95d327f4e00792b8e6806b03ec6d294f181c2f4.tar.xz
nixlib-f95d327f4e00792b8e6806b03ec6d294f181c2f4.tar.zst
nixlib-f95d327f4e00792b8e6806b03ec6d294f181c2f4.zip
haskell-primitive: avoid infinite recursion during evaluation
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/haskell-modules/configuration-nix.nix4
1 files changed, 4 insertions, 0 deletions
diff --git a/pkgs/development/haskell-modules/configuration-nix.nix b/pkgs/development/haskell-modules/configuration-nix.nix
index 813ab160a2cf..da63ec0c22a0 100644
--- a/pkgs/development/haskell-modules/configuration-nix.nix
+++ b/pkgs/development/haskell-modules/configuration-nix.nix
@@ -706,4 +706,8 @@ self: super: builtins.intersectAttrs super {
         wrapProgram $out/bin/mplayer-spot --prefix PATH : "${path}"
       '';
     });
+
+  # break infinite recursion with base-orphans
+  primitive = dontCheck super.primitive;
+
 }