about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorPeter Simons <simons@cryp.to>2019-05-12 09:26:55 +0000
committerPeter Simons <simons@cryp.to>2019-05-12 20:49:16 +0200
commitf944f8f9c5b498db9eec473d1c2e1ad670f66395 (patch)
tree52d9231dd5833040de68d83b0ace2b8e7e647e6d /pkgs/development
parentaa62499290f06ce486bcec7852a54949c8d7bd31 (diff)
downloadnixlib-f944f8f9c5b498db9eec473d1c2e1ad670f66395.tar
nixlib-f944f8f9c5b498db9eec473d1c2e1ad670f66395.tar.gz
nixlib-f944f8f9c5b498db9eec473d1c2e1ad670f66395.tar.bz2
nixlib-f944f8f9c5b498db9eec473d1c2e1ad670f66395.tar.lz
nixlib-f944f8f9c5b498db9eec473d1c2e1ad670f66395.tar.xz
nixlib-f944f8f9c5b498db9eec473d1c2e1ad670f66395.tar.zst
nixlib-f944f8f9c5b498db9eec473d1c2e1ad670f66395.zip
haskell-cabal-install: update ghc-8.8.x package set to latest git version
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/haskell-modules/configuration-ghc-8.8.x.nix26
1 files changed, 24 insertions, 2 deletions
diff --git a/pkgs/development/haskell-modules/configuration-ghc-8.8.x.nix b/pkgs/development/haskell-modules/configuration-ghc-8.8.x.nix
index 5f236f776852..68743a4dd579 100644
--- a/pkgs/development/haskell-modules/configuration-ghc-8.8.x.nix
+++ b/pkgs/development/haskell-modules/configuration-ghc-8.8.x.nix
@@ -41,8 +41,30 @@ self: super: {
   unix = null;
   xhtml = null;
 
-  # Use our native version of the Cabal library.
-  cabal-install = (doJailbreak super.cabal-install).overrideScope (self: super: { Cabal = null; });
+  # Use the current git version of cabal-install.
+  cabal-install = overrideCabal (super.cabal-install.overrideScope (self: super: { Cabal = self.Cabal-git; })) (drv: {
+    src = pkgs.fetchFromGitHub {
+      owner = "haskell";
+      repo = "cabal";
+      rev = "e98f6c26fa301b49921c2df67934bf9b0a4f3386";
+      sha256 = "15nrkvckq2rw31z7grgbsg5f0gxfc09afsrqdfi4n471k630xd2i";
+    };
+    version = "20190510-git";
+    editedCabalFile = null;
+    postUnpack = "sourceRoot+=/cabal-install";
+    jailbreak = true;
+  });
+  Cabal-git = overrideCabal super.Cabal_2_4_1_0 (drv: {
+    src = pkgs.fetchFromGitHub {
+      owner = "haskell";
+      repo = "cabal";
+      rev = "e98f6c26fa301b49921c2df67934bf9b0a4f3386";
+      sha256 = "15nrkvckq2rw31z7grgbsg5f0gxfc09afsrqdfi4n471k630xd2i";
+    };
+    version = "20190510-git";
+    editedCabalFile = null;
+    postUnpack = "sourceRoot+=/Cabal";
+  });
 
   # Ignore overly restrictive upper version bounds.
   async = doJailbreak super.async;