about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorEric Seidel <github@eric.seidel.io>2015-05-15 09:06:00 -0700
committerEric Seidel <github@eric.seidel.io>2015-05-15 09:06:00 -0700
commitf93a8ee1105f4cc3770ce339a8c1a4acea3b2fb6 (patch)
tree9ffaede374c1db9bc05ea18953589389896e5de6 /pkgs/development
parent92587ccc1f31af50aa79cdde4ad753eb33ce7e09 (diff)
parent5d82c6712910fedc07574bbaa61d69cf52779b38 (diff)
downloadnixlib-f93a8ee1105f4cc3770ce339a8c1a4acea3b2fb6.tar
nixlib-f93a8ee1105f4cc3770ce339a8c1a4acea3b2fb6.tar.gz
nixlib-f93a8ee1105f4cc3770ce339a8c1a4acea3b2fb6.tar.bz2
nixlib-f93a8ee1105f4cc3770ce339a8c1a4acea3b2fb6.tar.lz
nixlib-f93a8ee1105f4cc3770ce339a8c1a4acea3b2fb6.tar.xz
nixlib-f93a8ee1105f4cc3770ce339a8c1a4acea3b2fb6.tar.zst
nixlib-f93a8ee1105f4cc3770ce339a8c1a4acea3b2fb6.zip
Merge pull request #7845 from spwhitt/misc
Darwin: A couple fixes
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/interpreters/ruby/ruby-1.8.7.nix3
-rw-r--r--pkgs/development/libraries/botan/generic.nix2
-rw-r--r--pkgs/development/libraries/libdvbpsi/default.nix2
-rw-r--r--pkgs/development/libraries/libev/default.nix5
-rw-r--r--pkgs/development/libraries/nghttp2/default.nix6
5 files changed, 16 insertions, 2 deletions
diff --git a/pkgs/development/interpreters/ruby/ruby-1.8.7.nix b/pkgs/development/interpreters/ruby/ruby-1.8.7.nix
index 3c2ea71ecf26..0ae1d1261eed 100644
--- a/pkgs/development/interpreters/ruby/ruby-1.8.7.nix
+++ b/pkgs/development/interpreters/ruby/ruby-1.8.7.nix
@@ -60,6 +60,9 @@ stdenv.mkDerivation rec {
   ];
 
   configureFlags = [ "--enable-shared" "--enable-pthread" ]
+    # Without this fails due to not finding X11/Xlib.h
+    # Not sure why this isn't required on Linux
+    ++ ops stdenv.isDarwin [ "--without-tcl" "--without-tk" ]
     ++ op useRailsExpress "--with-baseruby=${baseruby}/bin/ruby";
 
   installFlags = stdenv.lib.optionalString docSupport "install-doc";
diff --git a/pkgs/development/libraries/botan/generic.nix b/pkgs/development/libraries/botan/generic.nix
index c843a00b8362..5880ae772ceb 100644
--- a/pkgs/development/libraries/botan/generic.nix
+++ b/pkgs/development/libraries/botan/generic.nix
@@ -21,7 +21,7 @@ stdenv.mkDerivation rec {
   buildInputs = [ python bzip2 zlib gmp openssl boost ];
 
   configurePhase = ''
-    python configure.py --prefix=$out --with-bzip2 --with-zlib ${if openssl != null then "--with-openssl" else ""} ${extraConfigureFlags}
+    python configure.py --prefix=$out --with-bzip2 --with-zlib ${if openssl != null then "--with-openssl" else ""} ${extraConfigureFlags}${if stdenv.cc.isClang then " --cc=clang" else "" }
   '';
 
   enableParallelBuilding = true;
diff --git a/pkgs/development/libraries/libdvbpsi/default.nix b/pkgs/development/libraries/libdvbpsi/default.nix
index 6af8e7a415e2..f8b9e9ecef90 100644
--- a/pkgs/development/libraries/libdvbpsi/default.nix
+++ b/pkgs/development/libraries/libdvbpsi/default.nix
@@ -12,7 +12,7 @@ stdenv.mkDerivation {
   meta = {
     description = "A simple library designed for decoding and generation of MPEG TS and DVB PSI tables according to standards ISO/IEC 13818 and ITU-T H.222.0";
     homepage = http://www.videolan.org/developers/libdvbpsi.html ;
-    platforms = stdenv.lib.platforms.linux;
+    platforms = stdenv.lib.platforms.unix;
     license = stdenv.lib.licenses.lgpl21;
   };
 
diff --git a/pkgs/development/libraries/libev/default.nix b/pkgs/development/libraries/libev/default.nix
index 90cab2cc6871..ce7d7b9e2759 100644
--- a/pkgs/development/libraries/libev/default.nix
+++ b/pkgs/development/libraries/libev/default.nix
@@ -7,6 +7,11 @@ stdenv.mkDerivation rec {
     url = "http://dist.schmorp.de/libev/${name}.tar.gz";
     sha256 = "1jyw7qbl0spxqa0dccj9x1jsw7cj7szff43cq4acmklnra4mzz48";
   };
+
+  # Version 4.19 is not valid C11 (which Clang default to)
+  # Check if this is still necessary on upgrade
+  NIX_CFLAGS_COMPILE = if stdenv.cc.isClang then "-std=c99" else null;
+
   meta = {
     description = "A high-performance event loop/event model with lots of features";
     maintainers = [ stdenv.lib.maintainers.raskin ];
diff --git a/pkgs/development/libraries/nghttp2/default.nix b/pkgs/development/libraries/nghttp2/default.nix
index e442cc96d2f7..bc8c599a901f 100644
--- a/pkgs/development/libraries/nghttp2/default.nix
+++ b/pkgs/development/libraries/nghttp2/default.nix
@@ -42,6 +42,12 @@ stdenv.mkDerivation rec {
     sha256 = "000d50yzyysbr9ldhvnbpzn35vplqm08dnmh55wc5zk273gy383f";
   };
 
+  # Configure script searches for a symbol which does not exist in jemalloc on Darwin
+  # Reported upstream in https://github.com/tatsuhiro-t/nghttp2/issues/233
+  postPatch = if (stdenv.isDarwin && optJemalloc != null) then ''
+    substituteInPlace configure --replace "malloc_stats_print" "je_malloc_stats_print"
+  '' else null;
+
   nativeBuildInputs = [ pkgconfig ];
   buildInputs = [ optJansson optBoost optLibxml2 optJemalloc ]
     ++ stdenv.lib.optionals hasApp [ optOpenssl optLibev optZlib ];