about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authoradisbladis <adisbladis@gmail.com>2018-01-11 09:54:33 +0800
committerGitHub <noreply@github.com>2018-01-11 09:54:33 +0800
commitf5e39b2c26d3e423bc6af8441233da28274a4495 (patch)
tree6a9112e01bd905d95149c11f3986b57ba39b31fb /pkgs/development
parent7f5a8599066b4a623fd98d4358e18a1e0a08a104 (diff)
parent1f2e24741664da7d129dfd2e1ecdb0efd901abdc (diff)
downloadnixlib-f5e39b2c26d3e423bc6af8441233da28274a4495.tar
nixlib-f5e39b2c26d3e423bc6af8441233da28274a4495.tar.gz
nixlib-f5e39b2c26d3e423bc6af8441233da28274a4495.tar.bz2
nixlib-f5e39b2c26d3e423bc6af8441233da28274a4495.tar.lz
nixlib-f5e39b2c26d3e423bc6af8441233da28274a4495.tar.xz
nixlib-f5e39b2c26d3e423bc6af8441233da28274a4495.tar.zst
nixlib-f5e39b2c26d3e423bc6af8441233da28274a4495.zip
Merge pull request #33727 from jluttine/update-salmon
pythonPackages.salmon: bec795cd -> 3.0.0
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/python-modules/salmon-mail/default.nix23
-rw-r--r--pkgs/development/python-modules/salmon/default.nix29
2 files changed, 23 insertions, 29 deletions
diff --git a/pkgs/development/python-modules/salmon-mail/default.nix b/pkgs/development/python-modules/salmon-mail/default.nix
new file mode 100644
index 000000000000..37c7b157ea58
--- /dev/null
+++ b/pkgs/development/python-modules/salmon-mail/default.nix
@@ -0,0 +1,23 @@
+{ stdenv, buildPythonPackage, fetchPypi, pythonOlder, nose, dnspython
+,  chardet, lmtpd, pythondaemon, six, jinja2, mock }:
+
+buildPythonPackage rec {
+  name = "${pname}-${version}";
+  pname = "salmon-mail";
+  version = "3.0.0";
+
+  src = fetchPypi {
+    inherit pname version;
+    sha256 = "1smggsnkwiqy8zjq604dkm5g0np27pdnj3szsbn8v4ja84nncq18";
+  };
+
+  checkInputs = [ nose jinja2 mock ];
+  propagatedBuildInputs = [ chardet dnspython lmtpd pythondaemon six ];
+
+  meta = with stdenv.lib; {
+    homepage = http://salmon-mail.readthedocs.org/;
+    description = "Pythonic mail application server";
+    license = licenses.gpl3;
+    maintainers = with maintainers; [ jluttine ];
+  };
+}
diff --git a/pkgs/development/python-modules/salmon/default.nix b/pkgs/development/python-modules/salmon/default.nix
deleted file mode 100644
index f9d7f79164ac..000000000000
--- a/pkgs/development/python-modules/salmon/default.nix
+++ /dev/null
@@ -1,29 +0,0 @@
-{ stdenv, buildPythonPackage, fetchFromGitHub, pythonOlder, nose, dnspython
-,  chardet, lmtpd, pythondaemon, six, jinja2, mock }:
-
-buildPythonPackage rec {
-  pname = "salmon";
-  # NOTE: The latest release version 2 is over 3 years old. So let's use some
-  # recent commit from master. There will be a new release at some point, then
-  # one can change this to use PyPI. See:
-  # https://github.com/moggers87/salmon/issues/52
-  version = "bec795cdab744be4f103d8e35584dfee622ddab2";
-  name = "${pname}-${version}";
-
-  src = fetchFromGitHub {
-    owner = "moggers87";
-    repo = "salmon";
-    rev = version;
-    sha256 = "0nx8pyxy7n42nsqqvhd85ycm1i5wlacsi7lwb4rrs9d416bpd300";
-  };
-
-  checkInputs = [ nose jinja2 mock ];
-  propagatedBuildInputs = [ chardet dnspython lmtpd pythondaemon six ];
-
-  meta = with stdenv.lib; {
-    homepage = http://salmon-mail.readthedocs.org/;
-    description = "Pythonic mail application server";
-    license = licenses.gpl3;
-    maintainers = with maintainers; [ jluttine ];
-  };
-}