about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorMario Rodas <marsam@users.noreply.github.com>2020-03-21 05:55:00 -0500
committerMario Rodas <marsam@users.noreply.github.com>2020-03-21 05:55:00 -0500
commitf3c3ecae33c4c4914e91c6df1170de58c7968a47 (patch)
tree97452a3a9494a6a6958c67aeea09d6ab4102802c /pkgs/development
parent42b14764abe9f68ad318657741cadb42a3db4bd9 (diff)
downloadnixlib-f3c3ecae33c4c4914e91c6df1170de58c7968a47.tar
nixlib-f3c3ecae33c4c4914e91c6df1170de58c7968a47.tar.gz
nixlib-f3c3ecae33c4c4914e91c6df1170de58c7968a47.tar.bz2
nixlib-f3c3ecae33c4c4914e91c6df1170de58c7968a47.tar.lz
nixlib-f3c3ecae33c4c4914e91c6df1170de58c7968a47.tar.xz
nixlib-f3c3ecae33c4c4914e91c6df1170de58c7968a47.tar.zst
nixlib-f3c3ecae33c4c4914e91c6df1170de58c7968a47.zip
prototol: fix build on darwin
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/tools/prototool/default.nix6
1 files changed, 4 insertions, 2 deletions
diff --git a/pkgs/development/tools/prototool/default.nix b/pkgs/development/tools/prototool/default.nix
index 37b0f1fdf8db..15a854e4d86c 100644
--- a/pkgs/development/tools/prototool/default.nix
+++ b/pkgs/development/tools/prototool/default.nix
@@ -1,4 +1,4 @@
-{ lib, buildGoModule, fetchFromGitHub, makeWrapper, protobuf }:
+{ stdenv, buildGoModule, fetchFromGitHub, makeWrapper, protobuf, Security }:
 
 buildGoModule rec {
   pname = "prototool";
@@ -13,6 +13,8 @@ buildGoModule rec {
 
   nativeBuildInputs = [ makeWrapper ];
 
+  buildInputs = stdenv.lib.optionals stdenv.isDarwin [ Security ];
+
   modSha256 = "1gc8kc9mbi3mlh48zx4lcgpsrf8z879f1qj9wfyr66s7wd1ljazg";
 
   postInstall = ''
@@ -23,7 +25,7 @@ buildGoModule rec {
 
   subPackages = [ "cmd/prototool" ];
 
-  meta = with lib; {
+  meta = with stdenv.lib; {
     homepage = "https://github.com/uber/prototool";
     description = "Your Swiss Army Knife for Protocol Buffers";
     maintainers = [ maintainers.marsam ];