about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorxeji <36407913+xeji@users.noreply.github.com>2018-09-19 23:50:22 +0200
committerGitHub <noreply@github.com>2018-09-19 23:50:22 +0200
commitf3a0c8a3aafb30d6a57e92b4b0b0245510d5a844 (patch)
tree4ea966744384a4d318d7552b648bb287ace7cf6b /pkgs/development
parent82cc6a7510d932542eae1b8e17846f98fd24e12c (diff)
downloadnixlib-f3a0c8a3aafb30d6a57e92b4b0b0245510d5a844.tar
nixlib-f3a0c8a3aafb30d6a57e92b4b0b0245510d5a844.tar.gz
nixlib-f3a0c8a3aafb30d6a57e92b4b0b0245510d5a844.tar.bz2
nixlib-f3a0c8a3aafb30d6a57e92b4b0b0245510d5a844.tar.lz
nixlib-f3a0c8a3aafb30d6a57e92b4b0b0245510d5a844.tar.xz
nixlib-f3a0c8a3aafb30d6a57e92b4b0b0245510d5a844.tar.zst
nixlib-f3a0c8a3aafb30d6a57e92b4b0b0245510d5a844.zip
pythonPackages.nilearn: disable still failing tests (#46918)
A previous attempt to fix tests failing on some machines (#46850)
was unsuccessful, they still failed on Hydra sometimes while
succeeding locally. Revert #46850 and disable these tests instead.
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/python-modules/nilearn/default.nix10
1 files changed, 2 insertions, 8 deletions
diff --git a/pkgs/development/python-modules/nilearn/default.nix b/pkgs/development/python-modules/nilearn/default.nix
index 14bb15184b59..32ec4b74509d 100644
--- a/pkgs/development/python-modules/nilearn/default.nix
+++ b/pkgs/development/python-modules/nilearn/default.nix
@@ -14,18 +14,12 @@ buildPythonPackage rec {
   # disable some failing tests
   checkPhase = ''
     nosetests nilearn/tests \
-    -e test_cache_mixin_with_expand_user -e test_clean_confounds -e test_detrend
+    -e test_cache_mixin_with_expand_user -e test_clean_confounds -e test_detrend \
+    -e test_clean_detrending -e test_high_variance_confounds
   '';
 
   checkInputs = [ nose ];
 
-  # These tests fail on some builder machines, probably due to lower
-  # arithmetic precision. Reduce required precision from 13 to 8 decimals.
-  postPatch = ''
-    substituteInPlace nilearn/tests/test_signal.py \
-      --replace 'decimal=13' 'decimal=8'
-  '';
-
   propagatedBuildInputs = [
     matplotlib
     nibabel