about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorSilvan Mosberger <contact@infinisil.com>2020-02-21 05:13:34 +0100
committerPeter Simons <simons@cryp.to>2020-02-28 20:31:25 +0100
commitef30908eef916f6430a0b290c47703c238576cc2 (patch)
tree116243f7ff7444b51eb8f4525f6e0c80e3b35ac5 /pkgs/development
parentb35908068848009062b2b1abca7cc3752b7271d5 (diff)
downloadnixlib-ef30908eef916f6430a0b290c47703c238576cc2.tar
nixlib-ef30908eef916f6430a0b290c47703c238576cc2.tar.gz
nixlib-ef30908eef916f6430a0b290c47703c238576cc2.tar.bz2
nixlib-ef30908eef916f6430a0b290c47703c238576cc2.tar.lz
nixlib-ef30908eef916f6430a0b290c47703c238576cc2.tar.xz
nixlib-ef30908eef916f6430a0b290c47703c238576cc2.tar.zst
nixlib-ef30908eef916f6430a0b290c47703c238576cc2.zip
haskellPackages.streamly-bytestring: Fix build
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/haskell-modules/configuration-common.nix5
1 files changed, 5 insertions, 0 deletions
diff --git a/pkgs/development/haskell-modules/configuration-common.nix b/pkgs/development/haskell-modules/configuration-common.nix
index 83555d252f4b..7248a820de77 100644
--- a/pkgs/development/haskell-modules/configuration-common.nix
+++ b/pkgs/development/haskell-modules/configuration-common.nix
@@ -1476,4 +1476,9 @@ self: super: {
     monoid-subclasses = self.monoid-subclasses_1_0_1;
   });
 
+  # Needs more recent streamly version
+  streamly-bytestring = super.streamly-bytestring.override {
+    streamly = self.streamly_0_7_1;
+  };
+
 } // import ./configuration-tensorflow.nix {inherit pkgs haskellLib;} self super