about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorJohannes Bornhold <johannes@bornhold.name>2015-09-06 01:01:16 +0200
committerVladimír Čunát <vcunat@gmail.com>2015-09-17 21:19:47 +0200
commitee799e05bfa8d9189d392bb0faaef31d52565d40 (patch)
tree62ff3adaa4b41b3c32fe25a4ac628d20a893c491 /pkgs/development
parentd006578d40b56753ccb899f6dc5ca63278228436 (diff)
downloadnixlib-ee799e05bfa8d9189d392bb0faaef31d52565d40.tar
nixlib-ee799e05bfa8d9189d392bb0faaef31d52565d40.tar.gz
nixlib-ee799e05bfa8d9189d392bb0faaef31d52565d40.tar.bz2
nixlib-ee799e05bfa8d9189d392bb0faaef31d52565d40.tar.lz
nixlib-ee799e05bfa8d9189d392bb0faaef31d52565d40.tar.xz
nixlib-ee799e05bfa8d9189d392bb0faaef31d52565d40.tar.zst
nixlib-ee799e05bfa8d9189d392bb0faaef31d52565d40.zip
dmd: Disable unsupported linker flags if stdenv.isClang
Close #9692.
Was able to build dmd on darwin, but it could not be used due to those flags.
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/compilers/dmd/default.nix3
1 files changed, 2 insertions, 1 deletions
diff --git a/pkgs/development/compilers/dmd/default.nix b/pkgs/development/compilers/dmd/default.nix
index fb4666de4c21..8b0f2509a911 100644
--- a/pkgs/development/compilers/dmd/default.nix
+++ b/pkgs/development/compilers/dmd/default.nix
@@ -15,6 +15,7 @@ stdenv.mkDerivation {
       substituteInPlace src/dmd/posix.mak --replace g++ clang++
   '';
 
+  # Buid and install are based on http://wiki.dlang.org/Building_DMD
   buildPhase = ''
       cd src/dmd
       make -f posix.mak INSTALL_DIR=$out
@@ -50,7 +51,7 @@ stdenv.mkDerivation {
       cd $out/bin
       tee dmd.conf << EOF
       [Environment]
-      DFLAGS=-I$out/include/d2 -L-L$out/lib -L--no-warn-search-mismatch -L--export-dynamic
+      DFLAGS=-I$out/include/d2 -L-L$out/lib ${stdenv.lib.optionalString (!stdenv.cc.isClang) "-L--no-warn-search-mismatch -L--export-dynamic"}
       EOF
   '';