about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorChris Ostrouchov <chris.ostrouchov@gmail.com>2018-11-27 16:52:34 -0500
committerChris Ostrouchov <chris.ostrouchov@gmail.com>2019-02-23 13:09:04 -0500
commiteb36c3f28c26ac8c82b548dbf8ee3b15595405f7 (patch)
tree9cdec5228345d7aab04421ddee8bfecff4497408 /pkgs/development
parentce019e775fd412d1522d3f0b232766ab1bd8dd7d (diff)
downloadnixlib-eb36c3f28c26ac8c82b548dbf8ee3b15595405f7.tar
nixlib-eb36c3f28c26ac8c82b548dbf8ee3b15595405f7.tar.gz
nixlib-eb36c3f28c26ac8c82b548dbf8ee3b15595405f7.tar.bz2
nixlib-eb36c3f28c26ac8c82b548dbf8ee3b15595405f7.tar.lz
nixlib-eb36c3f28c26ac8c82b548dbf8ee3b15595405f7.tar.xz
nixlib-eb36c3f28c26ac8c82b548dbf8ee3b15595405f7.tar.zst
nixlib-eb36c3f28c26ac8c82b548dbf8ee3b15595405f7.zip
libgumath: init at unstable-2018-11-27
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/libraries/libgumath/default.nix34
1 files changed, 34 insertions, 0 deletions
diff --git a/pkgs/development/libraries/libgumath/default.nix b/pkgs/development/libraries/libgumath/default.nix
new file mode 100644
index 000000000000..d5d35678b4fb
--- /dev/null
+++ b/pkgs/development/libraries/libgumath/default.nix
@@ -0,0 +1,34 @@
+{ stdenv
+, fetchFromGitHub
+, libndtypes
+, libxnd
+}:
+
+stdenv.mkDerivation rec {
+  name = "libgumath-${version}";
+  version = "unstable-2018-11-27";
+
+  src = fetchFromGitHub {
+    owner = "plures";
+    repo = "gumath";
+    rev = "5a9d27883b40432246d6a93cd6133157267fd166";
+    sha256 = "0w2qzp7anxd1wzkvv5r2pdkkpgrnqzgrq47lrvpqc1i1wqzcwf0w";
+  };
+
+  buildInputs = [ libndtypes libxnd ];
+
+  # Override linker with cc (symlink to either gcc or clang)
+  # Library expects to use cc for linking
+  configureFlags = [
+    "LD=${stdenv.cc.targetPrefix}cc"
+  ];
+
+  doCheck = true;
+
+  meta = with stdenv.lib; {
+    description = "Library supporting function dispatch on general data containers. C base and Python wrapper";
+    homepage = https://xnd.io/;
+    license = licenses.bsd3;
+    maintainers = [ maintainers.costrouc ];
+  };
+}