about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorVladimír Čunát <vcunat@gmail.com>2015-09-17 20:17:12 +0200
committerVladimír Čunát <vcunat@gmail.com>2015-09-17 20:17:12 +0200
commite922b6b0a2f40b4906274dc1acc2906c1e8b9a32 (patch)
tree141817e43c70715d8a52eafa3d3530bc0ed1107c /pkgs/development
parente8c1717ff488af06128210fba47d8ce917b53808 (diff)
downloadnixlib-e922b6b0a2f40b4906274dc1acc2906c1e8b9a32.tar
nixlib-e922b6b0a2f40b4906274dc1acc2906c1e8b9a32.tar.gz
nixlib-e922b6b0a2f40b4906274dc1acc2906c1e8b9a32.tar.bz2
nixlib-e922b6b0a2f40b4906274dc1acc2906c1e8b9a32.tar.lz
nixlib-e922b6b0a2f40b4906274dc1acc2906c1e8b9a32.tar.xz
nixlib-e922b6b0a2f40b4906274dc1acc2906c1e8b9a32.tar.zst
nixlib-e922b6b0a2f40b4906274dc1acc2906c1e8b9a32.zip
oracle{jdk,jre}: add meta.platforms to fix #9786
It won't be built by Hydra anyway due to being unfree.
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/compilers/oraclejdk/jdk-linux-base.nix5
1 files changed, 4 insertions, 1 deletions
diff --git a/pkgs/development/compilers/oraclejdk/jdk-linux-base.nix b/pkgs/development/compilers/oraclejdk/jdk-linux-base.nix
index c5588787922a..f4944e45c0e8 100644
--- a/pkgs/development/compilers/oraclejdk/jdk-linux-base.nix
+++ b/pkgs/development/compilers/oraclejdk/jdk-linux-base.nix
@@ -182,6 +182,9 @@ let result = stdenv.mkDerivation rec {
 
   passthru.home = result;
 
-  meta.license = stdenv.lib.licenses.unfree;
+  meta = with stdenv.lib; {
+    license = licenses.unfree;
+    platforms = [ "i686-linux" "x86_64-linux" ]; # some inherit jre.meta.platforms
+  };
 
 }; in result