about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorworldofpeace <worldofpeace@users.noreply.github.com>2019-02-16 23:26:49 -0500
committerworldofpeace <worldofpeace@users.noreply.github.com>2019-02-16 23:26:49 -0500
commite407f51aaff935e607b1c42f1ae1ce3d86d5515f (patch)
tree53acfa41820f91382d495d8fdd4b61866bb6a176 /pkgs/development
parentd55f53d019b26ea0b99bb50b09dd812cdd4e9700 (diff)
downloadnixlib-e407f51aaff935e607b1c42f1ae1ce3d86d5515f.tar
nixlib-e407f51aaff935e607b1c42f1ae1ce3d86d5515f.tar.gz
nixlib-e407f51aaff935e607b1c42f1ae1ce3d86d5515f.tar.bz2
nixlib-e407f51aaff935e607b1c42f1ae1ce3d86d5515f.tar.lz
nixlib-e407f51aaff935e607b1c42f1ae1ce3d86d5515f.tar.xz
nixlib-e407f51aaff935e607b1c42f1ae1ce3d86d5515f.tar.zst
nixlib-e407f51aaff935e607b1c42f1ae1ce3d86d5515f.zip
sysprof: 3.31.1 -> 3.30.2
This was accidentally updated to an unstable version
and is now at the latest stable release.
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/tools/profiling/sysprof/default.nix15
1 files changed, 7 insertions, 8 deletions
diff --git a/pkgs/development/tools/profiling/sysprof/default.nix b/pkgs/development/tools/profiling/sysprof/default.nix
index 8cd6a3f09eef..254b3d2283ed 100644
--- a/pkgs/development/tools/profiling/sysprof/default.nix
+++ b/pkgs/development/tools/profiling/sysprof/default.nix
@@ -15,17 +15,16 @@
 , wrapGAppsHook
 , gnome3
 }:
-let
-  version = "3.31.1";
+
+stdenv.mkDerivation rec {
   pname = "sysprof";
-in stdenv.mkDerivation rec {
-  name = "${pname}-${version}";
+  version = "3.30.2";
 
   outputs = [ "out" "lib" "dev" ];
 
   src = fetchurl {
-    url = "mirror://gnome/sources/${pname}/${stdenv.lib.versions.majorMinor version}/${name}.tar.xz";
-    sha256 = "0gjcd7agxn7cb8xnm8ldss1md7njwqzklqlsxclzqm87s7klnyrg";
+    url = "mirror://gnome/sources/${pname}/${stdenv.lib.versions.majorMinor version}/${pname}-${version}.tar.xz";
+    sha256 = "02xsr3cxyws3cnbhvbxgcc9sn22mri3iv9d7f38pkg89lpjph279";
   };
 
   nativeBuildInputs = [
@@ -63,7 +62,7 @@ in stdenv.mkDerivation rec {
       be restarted.
     '';
     license = licenses.gpl2Plus;
-    maintainers = with maintainers; [ ];
-    platforms = stdenv.lib.platforms.linux;
+    maintainers = gnome3.maintainers;
+    platforms = platforms.linux;
   };
 }