about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorPeter Simons <simons@cryp.to>2015-05-23 13:05:07 +0200
committerPeter Simons <simons@cryp.to>2015-05-23 15:09:29 +0200
commite25b42d852f950b5c54e9b0e6de91c23f3263fa7 (patch)
tree44eaae3bed490795615a7d59180bb567ffac401f /pkgs/development
parent70a7f7c14da197968a381a5890a5000656934a01 (diff)
downloadnixlib-e25b42d852f950b5c54e9b0e6de91c23f3263fa7.tar
nixlib-e25b42d852f950b5c54e9b0e6de91c23f3263fa7.tar.gz
nixlib-e25b42d852f950b5c54e9b0e6de91c23f3263fa7.tar.bz2
nixlib-e25b42d852f950b5c54e9b0e6de91c23f3263fa7.tar.lz
nixlib-e25b42d852f950b5c54e9b0e6de91c23f3263fa7.tar.xz
nixlib-e25b42d852f950b5c54e9b0e6de91c23f3263fa7.tar.zst
nixlib-e25b42d852f950b5c54e9b0e6de91c23f3263fa7.zip
cabal-install: avoid inconsistent 'binary' versions on ghc-7.4.x and ghc-7.6.x
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/haskell-modules/configuration-ghc-7.4.x.nix3
-rw-r--r--pkgs/development/haskell-modules/configuration-ghc-7.6.x.nix3
2 files changed, 6 insertions, 0 deletions
diff --git a/pkgs/development/haskell-modules/configuration-ghc-7.4.x.nix b/pkgs/development/haskell-modules/configuration-ghc-7.4.x.nix
index 88fa300e2e7f..2bad8d8b97d1 100644
--- a/pkgs/development/haskell-modules/configuration-ghc-7.4.x.nix
+++ b/pkgs/development/haskell-modules/configuration-ghc-7.4.x.nix
@@ -40,6 +40,9 @@ self: super: {
   # https://github.com/haskell/cabal/issues/2322
   Cabal_1_22_3_0 = super.Cabal_1_22_3_0.override { binary = self.binary_0_7_4_0; };
 
+  # Avoid inconsistent 'binary' versions from 'text' and 'Cabal'.
+  cabal-install = super.cabal-install.overrideScope (self: super: { binary = self.binary_0_7_4_0; });
+
   # https://github.com/tibbe/hashable/issues/85
   hashable = dontCheck super.hashable;
 
diff --git a/pkgs/development/haskell-modules/configuration-ghc-7.6.x.nix b/pkgs/development/haskell-modules/configuration-ghc-7.6.x.nix
index 2ee401054398..a90c5f99173a 100644
--- a/pkgs/development/haskell-modules/configuration-ghc-7.6.x.nix
+++ b/pkgs/development/haskell-modules/configuration-ghc-7.6.x.nix
@@ -42,6 +42,9 @@ self: super: {
   # https://github.com/haskell/cabal/issues/2322
   Cabal_1_22_3_0 = super.Cabal_1_22_3_0.override { binary = self.binary_0_7_4_0; };
 
+  # Avoid inconsistent 'binary' versions from 'text' and 'Cabal'.
+  cabal-install = super.cabal-install.overrideScope (self: super: { binary = self.binary_0_7_4_0; });
+
   # https://github.com/tibbe/hashable/issues/85
   hashable = dontCheck super.hashable;