about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorDmitry Kalinkin <dmitry.kalinkin@gmail.com>2020-04-04 23:31:27 -0400
committerGitHub <noreply@github.com>2020-04-04 23:31:27 -0400
commite163a369c7aff64dce900d0b492c07c53b8b4a14 (patch)
tree22ed59887a03b3c462afc8c765de6a0d7d023c0f /pkgs/development
parentbf681cff573d1c079d377db495674ac66f313976 (diff)
parentb6187aa5967e4ed33809d2916ef9398d4a9d6af9 (diff)
downloadnixlib-e163a369c7aff64dce900d0b492c07c53b8b4a14.tar
nixlib-e163a369c7aff64dce900d0b492c07c53b8b4a14.tar.gz
nixlib-e163a369c7aff64dce900d0b492c07c53b8b4a14.tar.bz2
nixlib-e163a369c7aff64dce900d0b492c07c53b8b4a14.tar.lz
nixlib-e163a369c7aff64dce900d0b492c07c53b8b4a14.tar.xz
nixlib-e163a369c7aff64dce900d0b492c07c53b8b4a14.tar.zst
nixlib-e163a369c7aff64dce900d0b492c07c53b8b4a14.zip
Merge pull request #83737 from veprbl/pr/libxslt_override_fix
libxml2,libxslt: fix pythonSupport=false override
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/libraries/libxslt/default.nix4
1 files changed, 1 insertions, 3 deletions
diff --git a/pkgs/development/libraries/libxslt/default.nix b/pkgs/development/libraries/libxslt/default.nix
index 6d12329a7f51..05da09ec5a46 100644
--- a/pkgs/development/libraries/libxslt/default.nix
+++ b/pkgs/development/libraries/libxslt/default.nix
@@ -3,9 +3,6 @@
 , pythonSupport ? stdenv.buildPlatform == stdenv.hostPlatform
 }:
 
-assert pythonSupport -> python != null;
-assert pythonSupport -> libxml2.pythonSupport;
-
 with stdenv.lib;
 
 stdenv.mkDerivation rec {
@@ -53,5 +50,6 @@ stdenv.mkDerivation rec {
     license = licenses.mit;
     platforms = platforms.all;
     maintainers = [ maintainers.eelco ];
+    broken = !(pythonSupport -> libxml2.pythonSupport); # see #73102 for why this is not an assert
   };
 }