about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorSilvan Mosberger <contact@infinisil.com>2020-02-21 04:33:29 +0100
committerPeter Simons <simons@cryp.to>2020-02-28 20:31:24 +0100
commitdf0392dc3c0f83c0a17ada119c1cc3b35be3f489 (patch)
tree237f8b9d2881c6a816d422b45173afb077976e2b /pkgs/development
parentfdb4ed35edc8fbdd952fb7ec91b9eafddd40f55e (diff)
downloadnixlib-df0392dc3c0f83c0a17ada119c1cc3b35be3f489.tar
nixlib-df0392dc3c0f83c0a17ada119c1cc3b35be3f489.tar.gz
nixlib-df0392dc3c0f83c0a17ada119c1cc3b35be3f489.tar.bz2
nixlib-df0392dc3c0f83c0a17ada119c1cc3b35be3f489.tar.lz
nixlib-df0392dc3c0f83c0a17ada119c1cc3b35be3f489.tar.xz
nixlib-df0392dc3c0f83c0a17ada119c1cc3b35be3f489.tar.zst
nixlib-df0392dc3c0f83c0a17ada119c1cc3b35be3f489.zip
haskellPackages.Chart-tests: Fix build
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/haskell-modules/configuration-common.nix7
1 files changed, 7 insertions, 0 deletions
diff --git a/pkgs/development/haskell-modules/configuration-common.nix b/pkgs/development/haskell-modules/configuration-common.nix
index 086c8c8df64c..9771b4518c0e 100644
--- a/pkgs/development/haskell-modules/configuration-common.nix
+++ b/pkgs/development/haskell-modules/configuration-common.nix
@@ -1460,4 +1460,11 @@ self: super: {
       # The appendConfigureFlags should remain even after we can drop patchedGtk.
       appendConfigureFlags patchedGtk (pkgs.lib.optional pkgs.stdenv.isDarwin "-f have-quartz-gtk");
 
+  # Chart-tests needs and compiles some modules from Chart itself
+  Chart-tests = (addExtraLibrary super.Chart-tests self.QuickCheck).overrideAttrs (old: {
+    preCheck = old.postPatch or "" + ''
+      tar --one-top-level=../chart --strip-components=1 -xf ${self.Chart.src}
+    '';
+  });
+
 } // import ./configuration-tensorflow.nix {inherit pkgs haskellLib;} self super