about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorFrederik Rietdijk <freddyrietdijk@fridh.nl>2018-05-17 08:53:03 +0200
committerGitHub <noreply@github.com>2018-05-17 08:53:03 +0200
commitde55b71e0bf1813da90707cdb5d1eafa650136a4 (patch)
tree419a141dc34bc957f084899b0c6bb36f1808686a /pkgs/development
parentfe2deeb4584e7da1d7018d74ec659fa6a0357e45 (diff)
parent51f4a46af29c4dc47659e687799146a2ac6c04af (diff)
downloadnixlib-de55b71e0bf1813da90707cdb5d1eafa650136a4.tar
nixlib-de55b71e0bf1813da90707cdb5d1eafa650136a4.tar.gz
nixlib-de55b71e0bf1813da90707cdb5d1eafa650136a4.tar.bz2
nixlib-de55b71e0bf1813da90707cdb5d1eafa650136a4.tar.lz
nixlib-de55b71e0bf1813da90707cdb5d1eafa650136a4.tar.xz
nixlib-de55b71e0bf1813da90707cdb5d1eafa650136a4.tar.zst
nixlib-de55b71e0bf1813da90707cdb5d1eafa650136a4.zip
Merge pull request #30833 from nyarly/jira_cli
(jira-cli) init at 2.2
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/python-modules/hiro/default.nix19
-rw-r--r--pkgs/development/python-modules/keyrings-alt/default.nix25
-rw-r--r--pkgs/development/tools/jira_cli/default.nix32
3 files changed, 76 insertions, 0 deletions
diff --git a/pkgs/development/python-modules/hiro/default.nix b/pkgs/development/python-modules/hiro/default.nix
new file mode 100644
index 000000000000..0289c008e7e8
--- /dev/null
+++ b/pkgs/development/python-modules/hiro/default.nix
@@ -0,0 +1,19 @@
+{ stdenv, buildPythonPackage, fetchPypi, six, mock }:
+buildPythonPackage rec {
+  pname = "hiro";
+  version = "0.1.4";
+  src = fetchPypi {
+    inherit pname version;
+
+    sha256 = "1340lhg7k522bqpz5iakl51qb47mjw804mfwwzm77i7qcm5cwiz8";
+  };
+
+  propagatedBuildInputs = [ six mock ];
+
+  meta = with stdenv.lib; {
+    description = "Time manipulation utilities for Python";
+    homepage = http://hiro.readthedocs.io/en/latest/;
+    license = licenses.mit;
+    maintainers = with maintainers; [ nyarly ];
+  };
+}
diff --git a/pkgs/development/python-modules/keyrings-alt/default.nix b/pkgs/development/python-modules/keyrings-alt/default.nix
new file mode 100644
index 000000000000..140d4297cda5
--- /dev/null
+++ b/pkgs/development/python-modules/keyrings-alt/default.nix
@@ -0,0 +1,25 @@
+{ stdenv, buildPythonPackage, fetchPypi, six
+, pytest, unittest2, mock, keyring
+}:
+
+buildPythonPackage rec {
+  pname = "keyrings.alt";
+  version = "2.3";
+
+  src = fetchPypi {
+    inherit pname version;
+    sha256 = "5cb9b6cdb5ce5e8216533e342d3e1b418ddd210466834061966d7dc1a4736f2d";
+  };
+  propagatedBuildInputs = [ six ];
+
+  # Fails with "ImportError: cannot import name mock"
+  doCheck = false;
+  checkInputs = [ pytest unittest2 mock keyring ];
+
+  meta = with stdenv.lib; {
+    license = licenses.mit;
+    description = "Alternate keyring implementations";
+    homepage = https://github.com/jaraco/keyrings.alt;
+    maintainers = with maintainers; [ nyarly ];
+  };
+}
diff --git a/pkgs/development/tools/jira_cli/default.nix b/pkgs/development/tools/jira_cli/default.nix
new file mode 100644
index 000000000000..37b76c50e902
--- /dev/null
+++ b/pkgs/development/tools/jira_cli/default.nix
@@ -0,0 +1,32 @@
+{ stdenv, libffi, openssl, pythonPackages }:
+let
+  inherit (pythonPackages) fetchPypi buildPythonApplication vcrpy mock hiro;
+in
+  buildPythonApplication rec {
+    pname = "jira-cli";
+    version = "2.2";
+    src = fetchPypi {
+      inherit pname version;
+      sha256 = "314118d5d851394ebf910122fd7ce871f63581393968c71456441eb56be3b112";
+    };
+
+    postPatch = ''
+      substituteInPlace requirements/main.txt --replace "argparse" ""
+    '';
+
+    # Tests rely on VCR cassettes being written during tests. R/O nix store prevents this.
+    doCheck = false;
+    checkInputs = with pythonPackages; [ vcrpy mock hiro ];
+    buildInputs = [ libffi openssl ];
+    propagatedBuildInputs = with pythonPackages; [
+      argparse ordereddict requests six suds-jurko termcolor keyring
+      jira  keyrings-alt
+    ];
+
+    meta = with stdenv.lib; {
+      description = "A command line interface to Jira";
+      homepage = http://github.com/alisaifee/jira-cli;
+      maintainers = with maintainers; [ nyarly ];
+      license = licenses.mit;
+    };
+  }