about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorBoris Babic <boris.ivan.babic@gmail.com>2019-01-06 03:29:14 +0100
committerworldofpeace <worldofpeace@users.noreply.github.com>2019-02-18 13:45:17 -0500
commitdd8b87d7b601c0a0d3cb7796bca0d4973df3d037 (patch)
tree93feb32f2950af0fab60fe908a7b2f3196621232 /pkgs/development
parent4bf34f16d8f4e703d4975f854d7c69378123cd8f (diff)
downloadnixlib-dd8b87d7b601c0a0d3cb7796bca0d4973df3d037.tar
nixlib-dd8b87d7b601c0a0d3cb7796bca0d4973df3d037.tar.gz
nixlib-dd8b87d7b601c0a0d3cb7796bca0d4973df3d037.tar.bz2
nixlib-dd8b87d7b601c0a0d3cb7796bca0d4973df3d037.tar.lz
nixlib-dd8b87d7b601c0a0d3cb7796bca0d4973df3d037.tar.xz
nixlib-dd8b87d7b601c0a0d3cb7796bca0d4973df3d037.tar.zst
nixlib-dd8b87d7b601c0a0d3cb7796bca0d4973df3d037.zip
pythonPackages.quamash: init at 0.6.1
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/python-modules/quamash/default.nix30
1 files changed, 30 insertions, 0 deletions
diff --git a/pkgs/development/python-modules/quamash/default.nix b/pkgs/development/python-modules/quamash/default.nix
new file mode 100644
index 000000000000..b39e081c4712
--- /dev/null
+++ b/pkgs/development/python-modules/quamash/default.nix
@@ -0,0 +1,30 @@
+{ lib, buildPythonPackage, fetchFromGitHub, pytest, isPy3k, pyqt5, pyqt ? pyqt5 }:
+
+buildPythonPackage rec {
+  pname = "quamash";
+  version = "0.6.1";
+
+  disabled = !isPy3k;
+
+  # No tests in PyPi tarball
+  src = fetchFromGitHub {
+    owner = "harvimt";
+    repo = "quamash";
+    rev = "version-${version}";
+    sha256 = "117rp9r4lz0kfz4dmmpa35hp6nhbh6b4xq0jmgvqm68g9hwdxmqa";
+  };
+
+  propagatedBuildInputs = [ pyqt ];
+
+  checkInputs = [ pytest ];
+  checkPhase = ''
+     pytest -k 'test_qthreadexec.py' # the others cause the test execution to be aborted, I think because of asyncio
+  '';
+
+  meta = with lib; {
+    description = "Implementation of the PEP 3156 event-loop (asyncio) api using the Qt Event-Loop";
+    homepage = https://github.com/harvimt/quamash;
+    license = licenses.bsd2;
+    maintainers = with maintainers; [ borisbabic ];
+  };
+}