about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorobadz <obadz-git@obadz.com>2016-08-11 16:41:06 +0100
committerobadz <obadz-git@obadz.com>2016-08-11 16:42:28 +0100
commitdaf44055cd4275d2226474e7b4f9df0eed82c6cc (patch)
tree1629ec7c3dcbe07c4f84755d9d0c6a95e68ae279 /pkgs/development
parent256394be60fb95a2fd7cf03b66388cba15da0203 (diff)
downloadnixlib-daf44055cd4275d2226474e7b4f9df0eed82c6cc.tar
nixlib-daf44055cd4275d2226474e7b4f9df0eed82c6cc.tar.gz
nixlib-daf44055cd4275d2226474e7b4f9df0eed82c6cc.tar.bz2
nixlib-daf44055cd4275d2226474e7b4f9df0eed82c6cc.tar.lz
nixlib-daf44055cd4275d2226474e7b4f9df0eed82c6cc.tar.xz
nixlib-daf44055cd4275d2226474e7b4f9df0eed82c6cc.tar.zst
nixlib-daf44055cd4275d2226474e7b4f9df0eed82c6cc.zip
haskellPackages.stunclient: fix build error due to changing exports in deps
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/haskell-modules/configuration-common.nix7
1 files changed, 7 insertions, 0 deletions
diff --git a/pkgs/development/haskell-modules/configuration-common.nix b/pkgs/development/haskell-modules/configuration-common.nix
index 8641de87b38c..5faceef85733 100644
--- a/pkgs/development/haskell-modules/configuration-common.nix
+++ b/pkgs/development/haskell-modules/configuration-common.nix
@@ -983,4 +983,11 @@ self: super: {
     })];
   });
 
+  # remove if a version > 0.1.0.1 ever gets released
+  stunclient = overrideCabal super.stunclient (drv: {
+    postPatch = (drv.postPatch or "") + ''
+      substituteInPlace source/Network/Stun/MappedAddress.hs --replace "import Network.Endian" ""
+    '';
+  });
+
 }