about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorLluís Batlle i Rossell <viric@vicerveza.homeunix.net>2010-04-12 19:23:14 +0000
committerLluís Batlle i Rossell <viric@vicerveza.homeunix.net>2010-04-12 19:23:14 +0000
commitd7cba8fc61442b6139e079ee8c6c63ad0d9557d0 (patch)
tree240e1a2e330c9be69c9f9635c9acdee5be00ccb6 /pkgs/development
parentcf70c1ecbc3b0ff71f41eb10c1bd76be5055f178 (diff)
downloadnixlib-d7cba8fc61442b6139e079ee8c6c63ad0d9557d0.tar
nixlib-d7cba8fc61442b6139e079ee8c6c63ad0d9557d0.tar.gz
nixlib-d7cba8fc61442b6139e079ee8c6c63ad0d9557d0.tar.bz2
nixlib-d7cba8fc61442b6139e079ee8c6c63ad0d9557d0.tar.lz
nixlib-d7cba8fc61442b6139e079ee8c6c63ad0d9557d0.tar.xz
nixlib-d7cba8fc61442b6139e079ee8c6c63ad0d9557d0.tar.zst
nixlib-d7cba8fc61442b6139e079ee8c6c63ad0d9557d0.zip
Adding rubygems/lib to RUBYLIB in wrapProgram for ruby libs.nix
Adding ncursesw, and feeding it to sup for wide character support

svn path=/nixpkgs/trunk/; revision=21032
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/interpreters/ruby/libs.nix24
1 files changed, 21 insertions, 3 deletions
diff --git a/pkgs/development/interpreters/ruby/libs.nix b/pkgs/development/interpreters/ruby/libs.nix
index 40be24210fdb..b486fc8526fe 100644
--- a/pkgs/development/interpreters/ruby/libs.nix
+++ b/pkgs/development/interpreters/ruby/libs.nix
@@ -33,9 +33,10 @@ let libs =
     # either the nameNoVersion or name must match
     patches = {
       sup = {
-        buildInputs = [ pkgs.ncurses pkgs.xapianBindings ];
+        buildInputs = [ pkgs.ncurses pkgs.xapianBindings libs.ncursesw ];
       };
       ncurses = { buildInputs = [ pkgs.ncurses ]; };
+      ncurses = { buildInputs = [ pkgs.ncurses ]; };
       nokogiri = {
         buildFlags=["--with-xml2-dir=${pkgs.libxml2} --with-xml2-include=${pkgs.libxml2}/include/libxml2"
                     "--with-xslt-dir=${pkgs.libxslt}" ];
@@ -122,7 +123,7 @@ let libs =
 
               for prog in $out/bin/*; do
                 wrapProgram "$prog" \
-                  --prefix RUBYLIB : "$RUBYLIB" \
+                  --prefix RUBYLIB : "$RUBYLIB":${rubygems}/lib \
                   --prefix GEM_PATH : "$GEM_PATH" \
                   --set RUBYOPT 'rubygems'
               done
@@ -154,7 +155,7 @@ let libs =
 
   # ================ START automatically generated code ================
          # WARNING: automatically generated CODE
-         # This section has been generated by gem nix sup chronic rubygems-update xrefresh-server rb-inotify jeweler
+         # This section has been generated by gem nix sup chronic rubygems-update xrefresh-server rb-inotify jeweler ncursesw
          # the gem nix command has been added by a nix patch to ruby gems
       
   json_pure_1_2_4 = rubyDerivation {
@@ -594,6 +595,22 @@ minutes of work.
      };
   };
 
+  ncursesw_1_2_4_1 = rubyDerivation {
+     name = "ruby-ncursesw-1.2.4.1"; # full_name
+     nameNoVersion = "ncursesw";
+     propagatedBuildInputs = [  ];
+     src = fetchurl {
+       url = "http://gems.rubyforge.org/gems/ncursesw-1.2.4.1.gem";
+       sha256 = "0cn13h14pk8yds8aklpdcpzl0z6rqifpmaz4lw29g10lgwvfv409";
+     };
+     meta = {
+       homepage = "http://ncurses-ruby.berlios.de/";
+       license = []; # one of ?
+       description = "Hacked up version of ncurses gem that supports wide characters and ruby1[...]";
+       longDescription = "Hacked up version of ncurses gem that supports wide characters and ruby1.9.1. Original ncurses gem by t-peters@users.berlios.de.";
+     };
+  };
+
 # aliases
 rmail=rmail_1_0_0;
 term_ansicolor=term_ansicolor_1_0_5;
@@ -619,5 +636,6 @@ chronic=chronic_0_2_3;
 json_pure=json_pure_1_2_4;
 lockfile=lockfile_1_4_3;
 ffi=ffi_0_6_3;
+ncursesw=ncursesw_1_2_4_1;
   # ================ END automatically generated code ================
   }; in libs