about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorSander van der Burg <svanderburg@gmail.com>2016-04-28 08:56:31 +0000
committerSander van der Burg <svanderburg@gmail.com>2016-04-28 08:56:31 +0000
commitd76982e18159f02d80cca5ef4fcb14b0dc70f42b (patch)
tree625978c48d71c3d7e75ca151222ec1f40b472051 /pkgs/development
parentd27caa486b03781768cacd7f17881f31adfe4ff8 (diff)
parentc893105f1f4497225a70961513726f5243a242f7 (diff)
downloadnixlib-d76982e18159f02d80cca5ef4fcb14b0dc70f42b.tar
nixlib-d76982e18159f02d80cca5ef4fcb14b0dc70f42b.tar.gz
nixlib-d76982e18159f02d80cca5ef4fcb14b0dc70f42b.tar.bz2
nixlib-d76982e18159f02d80cca5ef4fcb14b0dc70f42b.tar.lz
nixlib-d76982e18159f02d80cca5ef4fcb14b0dc70f42b.tar.xz
nixlib-d76982e18159f02d80cca5ef4fcb14b0dc70f42b.tar.zst
nixlib-d76982e18159f02d80cca5ef4fcb14b0dc70f42b.zip
Merge pull request #14973 from holidaycheck/update-libuv
libuv: 1.7.5 -> 1.9.0
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/libraries/libuv/default.nix87
-rw-r--r--pkgs/development/python-modules/pyuv-external-libuv.patch22
2 files changed, 26 insertions, 83 deletions
diff --git a/pkgs/development/libraries/libuv/default.nix b/pkgs/development/libraries/libuv/default.nix
index 48d12321248c..e039711e457b 100644
--- a/pkgs/development/libraries/libuv/default.nix
+++ b/pkgs/development/libraries/libuv/default.nix
@@ -2,84 +2,29 @@
 
 , ApplicationServices, CoreServices }:
 
-let
-  stable = "stable";
-  unstable = "unstable";
+stdenv.mkDerivation rec {
+  version = "1.9.0";
+  name = "libuv-${version}";
 
-  meta = with lib; {
-    description = "A multi-platform support library with a focus on asynchronous I/O";
-    homepage    = https://github.com/libuv/libuv;
-    maintainers = with maintainers; [ cstrahan ];
-    platforms   = with platforms; linux ++ darwin;
-  };
-
-  mkName = stability: version:
-    if stability == stable
-    then "libuv-${version}"
-    else "libuv-${stability}-${version}";
-
-  mkSrc = version: sha256: fetchFromGitHub {
+  src = fetchFromGitHub {
     owner = "libuv";
     repo = "libuv";
     rev = "v${version}";
-    inherit sha256;
+    sha256 = "0sq8c8n7xixn2xxp35crprvh35ry18i5mcxgwh12lydwv9ks0d4k";
   };
 
-  # for versions < 0.11.6
-  mkWithoutAutotools = stability: version: sha256: stdenv.mkDerivation {
-    name = mkName stability version;
-    src = mkSrc version sha256;
-    buildPhase = lib.optionalString stdenv.isDarwin ''
-      mkdir extrapath
-      ln -s /usr/sbin/dtrace extrapath/dtrace
-      export PATH=$PATH:`pwd`/extrapath
-    '' + ''
-      mkdir build
-      make builddir_name=build
+  buildInputs = [ automake autoconf libtool pkgconfig ]
+    ++ stdenv.lib.optionals stdenv.isDarwin [ ApplicationServices CoreServices ];
 
-      rm -r build/src
-      rm build/libuv.a
-      cp -r include build
+  preConfigure = ''
+    LIBTOOLIZE=libtoolize ./autogen.sh
+  '';
 
-      mkdir build/lib
-      mv build/libuv.* build/lib
-
-      pushd build/lib
-      lib=$(basename libuv.*)
-      ext="''${lib##*.}"
-      mv $lib libuv.10.$ext
-      ln -s libuv.10.$ext libuv.$ext
-      popd
-    '';
-    installPhase = ''
-      cp -r build $out
-    '';
-    inherit meta;
-  };
-
-  # for versions > 0.11.6
-  mkWithAutotools = stability: version: sha256: stdenv.mkDerivation {
-    name = mkName stability version;
-    src = mkSrc version sha256;
-    buildInputs = [ automake autoconf libtool pkgconfig ]
-      ++ stdenv.lib.optionals stdenv.isDarwin [ ApplicationServices CoreServices ];
-    preConfigure = ''
-      LIBTOOLIZE=libtoolize ./autogen.sh
-    '';
-    inherit meta;
+  meta = with lib; {
+    description = "A multi-platform support library with a focus on asynchronous I/O";
+    homepage    = https://github.com/libuv/libuv;
+    maintainers = with maintainers; [ cstrahan ];
+    platforms   = with platforms; linux ++ darwin;
   };
 
-  toVersion = with lib; name:
-    replaceChars ["_"] ["."] (removePrefix "v" name);
-
-in
-
-  with lib;
-
-  mapAttrs (v: h: mkWithAutotools unstable (toVersion v) h) {
-    v0_11_29 = "1z07phfwryfy2155p3lxcm2a33h20sfl96lds5dghn157x6csz7m";
-  }
-  //
-  mapAttrs (v: h: mkWithAutotools stable (toVersion v) h) {
-    v1_7_5 = "18x6cy2xn31am97vn6jli7kmb2fbp4c8kmv7jm97vggh0x55flsc";
-  }
+}
diff --git a/pkgs/development/python-modules/pyuv-external-libuv.patch b/pkgs/development/python-modules/pyuv-external-libuv.patch
index 33539d9b4b2c..41e169acd5f5 100644
--- a/pkgs/development/python-modules/pyuv-external-libuv.patch
+++ b/pkgs/development/python-modules/pyuv-external-libuv.patch
@@ -1,27 +1,25 @@
 diff --git a/setup.py b/setup.py
-index ec0caac..2c1fdb6 100644
+index 5071c3b..4b4a176 100644
 --- a/setup.py
 +++ b/setup.py
-@@ -6,7 +6,6 @@ try:
+@@ -7,7 +7,6 @@ try:
      from setuptools import setup, Extension
  except ImportError:
      from distutils.core import setup, Extension
 -from setup_libuv import libuv_build_ext, libuv_sdist
- 
- 
- __version__ = "0.11.5"
-@@ -32,12 +31,11 @@ setup(name             = "pyuv",
+
+
+ def get_version():
+@@ -35,11 +34,10 @@ setup(name             = "pyuv",
            "Programming Language :: Python :: 3.3",
            "Programming Language :: Python :: 3.4"
        ],
 -      cmdclass     = {'build_ext': libuv_build_ext,
 -                      'sdist'    : libuv_sdist},
-       ext_modules  = [Extension('pyuv',
+       packages     = ['pyuv'],
+       ext_modules  = [Extension('pyuv._cpyuv',
                                  sources = ['src/pyuv.c'],
-+                                libraries = ['uv'],
-                                 define_macros=[('MODULE_VERSION', __version__),
--                                               ('LIBUV_REVISION', libuv_build_ext.libuv_revision)]
-+                                               ('LIBUV_REVISION', 'unknown')]
++                                libraries = ['uv']
                       )]
       )
- 
+