about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorSebastian Jordan <sebastian.jordan.mail@googlemail.com>2019-10-26 23:37:45 +0200
committerJon <jonringer@users.noreply.github.com>2019-10-30 08:19:39 -0700
commitd6a2495f1d38e8b29e0d8de76345a037721b3b98 (patch)
treef3986151feb78d4295725b1bde433c718f158894 /pkgs/development
parent7fc6425d0218eb392733415f53692bc5fdd2cd20 (diff)
downloadnixlib-d6a2495f1d38e8b29e0d8de76345a037721b3b98.tar
nixlib-d6a2495f1d38e8b29e0d8de76345a037721b3b98.tar.gz
nixlib-d6a2495f1d38e8b29e0d8de76345a037721b3b98.tar.bz2
nixlib-d6a2495f1d38e8b29e0d8de76345a037721b3b98.tar.lz
nixlib-d6a2495f1d38e8b29e0d8de76345a037721b3b98.tar.xz
nixlib-d6a2495f1d38e8b29e0d8de76345a037721b3b98.tar.zst
nixlib-d6a2495f1d38e8b29e0d8de76345a037721b3b98.zip
pythonPackages.parsley: init at 1.3
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/python-modules/parsley/default.nix22
1 files changed, 22 insertions, 0 deletions
diff --git a/pkgs/development/python-modules/parsley/default.nix b/pkgs/development/python-modules/parsley/default.nix
new file mode 100644
index 000000000000..17e05b6027f2
--- /dev/null
+++ b/pkgs/development/python-modules/parsley/default.nix
@@ -0,0 +1,22 @@
+{ buildPythonPackage
+, fetchPypi
+, lib
+}:
+
+buildPythonPackage rec {
+  pname = "Parsley";
+  version = "1.3";
+  src = fetchPypi {
+    inherit pname version;
+    sha256 = "0hcd41bl07a8sx7nmx12p16xprnblc4phxkawwmmy78n8y6jfi4l";
+  };
+  # Tests fail although the package works just fine.  Unfortunately
+  # the tests as run by the upstream CI server travis.org are broken.
+  doCheck = false;
+  meta = with lib; {
+    license = licenses.mit;
+    homepage = "https://launchpad.net/parsley";
+    description = "A parser generator library based on OMeta, and other useful parsing tools.";
+    maintainers = with maintainers; [ seppeljordan ];
+  };
+}