about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorJonathan Ringer <jonringer117@gmail.com>2019-06-15 13:25:53 -0700
committerJonathan Ringer <jonringer117@gmail.com>2019-06-15 13:27:19 -0700
commitd20e963e91f9f70a3f814fd8d045722cd31d4116 (patch)
tree0e36b96c269bbfec0f41aa9b595e1df07c3c09f4 /pkgs/development
parent46ce40ba6a6f03d02d9ab7cad984c62baf488d6e (diff)
downloadnixlib-d20e963e91f9f70a3f814fd8d045722cd31d4116.tar
nixlib-d20e963e91f9f70a3f814fd8d045722cd31d4116.tar.gz
nixlib-d20e963e91f9f70a3f814fd8d045722cd31d4116.tar.bz2
nixlib-d20e963e91f9f70a3f814fd8d045722cd31d4116.tar.lz
nixlib-d20e963e91f9f70a3f814fd8d045722cd31d4116.tar.xz
nixlib-d20e963e91f9f70a3f814fd8d045722cd31d4116.tar.zst
nixlib-d20e963e91f9f70a3f814fd8d045722cd31d4116.zip
pythonPackages.pydocumentdb: init at 2.3.3
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/python-modules/pydocumentdb/default.nix28
1 files changed, 28 insertions, 0 deletions
diff --git a/pkgs/development/python-modules/pydocumentdb/default.nix b/pkgs/development/python-modules/pydocumentdb/default.nix
new file mode 100644
index 000000000000..4413f9eef2e7
--- /dev/null
+++ b/pkgs/development/python-modules/pydocumentdb/default.nix
@@ -0,0 +1,28 @@
+{ buildPythonPackage
+, lib
+, fetchPypi
+, six
+, requests
+}:
+
+buildPythonPackage rec {
+  version = "2.3.3";
+  pname = "pydocumentdb";
+
+  src = fetchPypi {
+    inherit pname version;
+    sha256 = "1fcp3g62pc9hpa0r6vdjhaln4h0azywjqfzi8bd4414ja0mxmj3p";
+  };
+
+  propagatedBuildInputs = [ six requests ];
+
+  # requires an active Azure Cosmos service
+  doCheck = false;
+
+  meta = with lib; {
+    description = "Azure Cosmos DB API";
+    homepage = https://github.com/Azure/azure-cosmos-python;
+    license = licenses.mit;
+    maintainers = with maintainers; [ jonringer ];
+  };
+}