about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorlethalman <lucabru@src.gnome.org>2014-12-22 11:16:44 +0100
committerlethalman <lucabru@src.gnome.org>2014-12-22 11:16:44 +0100
commitd0fdad5f36ceac69ce2b8a3f9a7d2622ad70fbff (patch)
tree1edd261ac912e5e82bcabd88a6cbcbd6542b3f41 /pkgs/development
parenta80f7d7c9699c58c0e9e6480f017d979147dcc48 (diff)
parent01910e84f9d16e1bff765d4dffb0defb4039bad6 (diff)
downloadnixlib-d0fdad5f36ceac69ce2b8a3f9a7d2622ad70fbff.tar
nixlib-d0fdad5f36ceac69ce2b8a3f9a7d2622ad70fbff.tar.gz
nixlib-d0fdad5f36ceac69ce2b8a3f9a7d2622ad70fbff.tar.bz2
nixlib-d0fdad5f36ceac69ce2b8a3f9a7d2622ad70fbff.tar.lz
nixlib-d0fdad5f36ceac69ce2b8a3f9a7d2622ad70fbff.tar.xz
nixlib-d0fdad5f36ceac69ce2b8a3f9a7d2622ad70fbff.tar.zst
nixlib-d0fdad5f36ceac69ce2b8a3f9a7d2622ad70fbff.zip
Merge pull request #5419 from ehmry/tox-bootstrapd
tox-bootstrapd
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/libraries/libtoxcore/default.nix16
1 files changed, 9 insertions, 7 deletions
diff --git a/pkgs/development/libraries/libtoxcore/default.nix b/pkgs/development/libraries/libtoxcore/default.nix
index d569cf28c37c..de224f6b613b 100644
--- a/pkgs/development/libraries/libtoxcore/default.nix
+++ b/pkgs/development/libraries/libtoxcore/default.nix
@@ -1,17 +1,18 @@
-{ stdenv, fetchurl, autoconf, libtool, automake, libsodium, ncurses, libopus
+{ stdenv, fetchFromGitHub, autoconf, libtool, automake, libsodium, ncurses, libopus
 , libvpx, check, libconfig, pkgconfig }:
 
 let
   version = "f6b3e6e8fe98d2457827ac6da944e715f008a08a";
-  date = "20141203";
+  date = "20141219";
 in
 stdenv.mkDerivation rec {
-  name = "tox-core-${date}-${version}";
+  name = "tox-core-${date}-${builtins.substring 0 7 version}";
 
-  src = fetchurl {
-    url = "https://github.com/irungentoo/toxcore/tarball/${version}";
-    name = "${name}.tar.gz";
-    sha256 = "1zsx7saqs25vva3pp0bw31yqzrn40fx84w42ig6fiv723k9gpdzy";
+  src = fetchFromGitHub {
+    owner  = "irungentoo";
+    repo   = "toxcore";
+    rev    = version;
+    sha256 = "1wd817kix3zjyzzb68jz02iir3z4y5k5p40dgl7a29757yb9m608";
   };
 
   NIX_LDFLAGS = "-lgcc_s";
@@ -33,6 +34,7 @@ stdenv.mkDerivation rec {
     "--with-libsodium-headers=${libsodium}/include"
     "--with-libsodium-libs=${libsodium}/lib"
     "--enable-ntox"
+    "--enable-daemon"
   ];
 
   buildInputs = [