about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorHerwig Hochleitner <herwig@bendlas.net>2018-12-20 20:03:26 +0100
committerHerwig Hochleitner <herwig@bendlas.net>2018-12-20 20:06:11 +0100
commitd06770b9a03b6fe1e2fe34c2026337c58c326af5 (patch)
tree91f771b1306b4ce07fdc08ee246d434c2fa6d3d8 /pkgs/development
parent539679ff35c4c4f115986e2bd68848df712d0733 (diff)
downloadnixlib-d06770b9a03b6fe1e2fe34c2026337c58c326af5.tar
nixlib-d06770b9a03b6fe1e2fe34c2026337c58c326af5.tar.gz
nixlib-d06770b9a03b6fe1e2fe34c2026337c58c326af5.tar.bz2
nixlib-d06770b9a03b6fe1e2fe34c2026337c58c326af5.tar.lz
nixlib-d06770b9a03b6fe1e2fe34c2026337c58c326af5.tar.xz
nixlib-d06770b9a03b6fe1e2fe34c2026337c58c326af5.tar.zst
nixlib-d06770b9a03b6fe1e2fe34c2026337c58c326af5.zip
allegro5: fix build for mesa 18.2.5
mesa 18.2.5, introduced in 6b490ee2964662d69f0d38e71f0dc3565ad49515
changed some private headers, that allegro is relying on. This fix backports
the relevant commit from allegro upstream

cc @7c6f434c
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/libraries/allegro/5.nix12
1 files changed, 10 insertions, 2 deletions
diff --git a/pkgs/development/libraries/allegro/5.nix b/pkgs/development/libraries/allegro/5.nix
index 5e82a1a3c6be..269a139a3d69 100644
--- a/pkgs/development/libraries/allegro/5.nix
+++ b/pkgs/development/libraries/allegro/5.nix
@@ -1,4 +1,4 @@
-{ stdenv, fetchFromGitHub, texinfo, libXext, xextproto, libX11, xproto
+{ stdenv, fetchFromGitHub, fetchpatch, texinfo, libXext, xextproto, libX11, xproto
 , libXpm, libXt, libXcursor, alsaLib, cmake, zlib, libpng, libvorbis
 , libXxf86dga, libXxf86misc, xf86dgaproto, xf86miscproto
 , xf86vidmodeproto, libXxf86vm, openal, libGLU_combined, kbproto, libjpeg, flac
@@ -28,7 +28,15 @@ stdenv.mkDerivation rec {
     libpulseaudio libpthreadstubs
   ];
 
-  patchPhase = ''
+  patches = [
+   # fix compilation with mesa 18.2.5
+   (fetchpatch {
+     url = "https://github.com/liballeg/allegro5/commit/a40d30e21802ecf5c9382cf34af9b01bd3781e47.patch";
+     sha256 = "1f1xlj5y2vr6wzmcz04s8kxn8cfdwrg9kjlnvpz9dix1z3qjnd4m";
+   })
+  ];
+
+  postPatch = ''
     sed -e 's@/XInput2.h@/XI2.h@g' -i CMakeLists.txt "src/"*.c
   '';