about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorFrederik Rietdijk <fridh@fridh.nl>2016-04-25 17:46:15 +0200
committerFrederik Rietdijk <fridh@fridh.nl>2016-04-25 17:46:15 +0200
commitd05783a8d7cc07760542f7f2fc30be576cb29ce6 (patch)
tree178cbd3460c37d7b2062a8fdca1eae69cb6b63d7 /pkgs/development
parent983f300d74852b5a4a810085a508d413d9c56a1f (diff)
downloadnixlib-d05783a8d7cc07760542f7f2fc30be576cb29ce6.tar
nixlib-d05783a8d7cc07760542f7f2fc30be576cb29ce6.tar.gz
nixlib-d05783a8d7cc07760542f7f2fc30be576cb29ce6.tar.bz2
nixlib-d05783a8d7cc07760542f7f2fc30be576cb29ce6.tar.lz
nixlib-d05783a8d7cc07760542f7f2fc30be576cb29ce6.tar.xz
nixlib-d05783a8d7cc07760542f7f2fc30be576cb29ce6.tar.zst
nixlib-d05783a8d7cc07760542f7f2fc30be576cb29ce6.zip
pythonPackages.scipy: don't propagate blas
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/python-modules/scipy.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/pkgs/development/python-modules/scipy.nix b/pkgs/development/python-modules/scipy.nix
index ae312cd32d59..b31f539ebdd4 100644
--- a/pkgs/development/python-modules/scipy.nix
+++ b/pkgs/development/python-modules/scipy.nix
@@ -9,8 +9,8 @@ in buildPythonPackage (args // rec {
 
   name = "scipy-${version}";
 
-  buildInputs = (args.buildInputs or [ gfortran nose ]);
-  propagatedBuildInputs = (args.propagatedBuildInputs or [ passthru.blas numpy]);
+  buildInputs = (args.buildInputs or [ gfortran nose passthru.blas ]);
+  propagatedBuildInputs = (args.propagatedBuildInputs or [ numpy]);
 
   preConfigure = ''
     sed -i '0,/from numpy.distutils.core/s//import setuptools;from numpy.distutils.core/' setup.py