about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorFlorian Klink <flokli@flokli.de>2020-01-11 21:53:02 +0100
committerFlorian Klink <flokli@flokli.de>2020-01-11 21:53:02 +0100
commitcd827f2209b35c4c3bdd5492c3e9a9d351e3e3b3 (patch)
treee6809a4640ae6a840869f0a12b965983a1bf01b7 /pkgs/development
parent5e515242936cdd11820fe567cd2f466b29f5e305 (diff)
downloadnixlib-cd827f2209b35c4c3bdd5492c3e9a9d351e3e3b3.tar
nixlib-cd827f2209b35c4c3bdd5492c3e9a9d351e3e3b3.tar.gz
nixlib-cd827f2209b35c4c3bdd5492c3e9a9d351e3e3b3.tar.bz2
nixlib-cd827f2209b35c4c3bdd5492c3e9a9d351e3e3b3.tar.lz
nixlib-cd827f2209b35c4c3bdd5492c3e9a9d351e3e3b3.tar.xz
nixlib-cd827f2209b35c4c3bdd5492c3e9a9d351e3e3b3.tar.zst
nixlib-cd827f2209b35c4c3bdd5492c3e9a9d351e3e3b3.zip
Revert "glibc: fix cross compilation build failure"
This reverts commit 51014768d2f2cc61fd70d39747f6d070583864ec.
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/libraries/glibc/common.nix5
-rw-r--r--pkgs/development/libraries/glibc/default.nix5
-rw-r--r--pkgs/development/libraries/glibc/fix-out-of-bounds-access-in-findidxwc.patch28
3 files changed, 0 insertions, 38 deletions
diff --git a/pkgs/development/libraries/glibc/common.nix b/pkgs/development/libraries/glibc/common.nix
index 690afc9971dc..32be2205bcc1 100644
--- a/pkgs/development/libraries/glibc/common.nix
+++ b/pkgs/development/libraries/glibc/common.nix
@@ -97,11 +97,6 @@ stdenv.mkDerivation ({
       ./CVE-2018-11236.patch
       # https://sourceware.org/git/gitweb.cgi?p=glibc.git;h=f51c8367685dc888a02f7304c729ed5277904aff
       ./CVE-2018-11237.patch
-
-      # Remove after upgrading to glibc 2.28+
-      # Change backported from upstream
-      # https://sourceware.org/git/gitweb.cgi?p=glibc.git;h=9c79cec8cd2a6996a73aa83d79b360ffd4bebde6
-      ./fix-out-of-bounds-access-in-findidxwc.patch
     ]
     ++ lib.optionals stdenv.isx86_64 [
       ./fix-x64-abi.patch
diff --git a/pkgs/development/libraries/glibc/default.nix b/pkgs/development/libraries/glibc/default.nix
index 9327e0d936c5..b2afc66acc6a 100644
--- a/pkgs/development/libraries/glibc/default.nix
+++ b/pkgs/development/libraries/glibc/default.nix
@@ -54,11 +54,6 @@ callPackage ./common.nix { inherit stdenv; } {
         # Fix -Werror build failure when building glibc with musl with GCC >= 8, see:
         # https://github.com/NixOS/nixpkgs/pull/68244#issuecomment-544307798
         (stdenv.lib.optional stdenv.hostPlatform.isMusl "-Wno-error=attribute-alias")
-        (stdenv.lib.optionals (stdenv.hostPlatform != stdenv.buildPlatform) [
-          # Ignore "error: '__EI___errno_location' specifies less restrictive attributes than its target '__errno_location'"
-          # New warning as of GCC 9
-          "-Wno-error=missing-attributes"
-        ])
       ]);
 
     # When building glibc from bootstrap-tools, we need libgcc_s at RPATH for
diff --git a/pkgs/development/libraries/glibc/fix-out-of-bounds-access-in-findidxwc.patch b/pkgs/development/libraries/glibc/fix-out-of-bounds-access-in-findidxwc.patch
deleted file mode 100644
index ffac4a38c841..000000000000
--- a/pkgs/development/libraries/glibc/fix-out-of-bounds-access-in-findidxwc.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-diff -ur glibc-2.27/locale/weightwc.h glibc-2.27-patched/locale/weightwc.h
---- glibc-2.27/locale/weightwc.h	2018-02-02 01:17:18.000000000 +0900
-+++ glibc-2.27-patched/locale/weightwc.h	2020-01-12 03:33:41.519720579 +0900
-@@ -73,7 +73,7 @@
- 	      break;
- 	  DIAG_POP_NEEDS_COMMENT;
- 
--	  if (cnt == nhere)
-+	  if (cnt == nhere || cnt == len)
- 	    {
- 	      /* Found it.  */
- 	      *cpp += nhere;
-@@ -100,13 +100,13 @@
- 	      continue;
- 	    }
- 
--	  if (cp[nhere - 1] > usrc[nhere -1])
-+	  if (cp[nhere - 1] > usrc[nhere - 1])
- 	    {
- 	      cp += 2 * nhere;
- 	      continue;
- 	    }
- 
--	  if (cp[2 * nhere - 1] < usrc[nhere -1])
-+	  if (cp[2 * nhere - 1] < usrc[nhere - 1])
- 	    {
- 	      cp += 2 * nhere;
- 	      continue;