about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorAlyssa Ross <hi@alyssa.is>2019-09-07 13:02:40 +0000
committerAlyssa Ross <hi@alyssa.is>2019-09-07 14:32:56 +0000
commitca96b55d3a4a6b671ae841f1ad416f80f065bd63 (patch)
tree0e64837b155b2665cee8e94ea479381187f629e3 /pkgs/development
parent3b5b9a73f59ff93d50156e250203410bdd07f4e0 (diff)
downloadnixlib-ca96b55d3a4a6b671ae841f1ad416f80f065bd63.tar
nixlib-ca96b55d3a4a6b671ae841f1ad416f80f065bd63.tar.gz
nixlib-ca96b55d3a4a6b671ae841f1ad416f80f065bd63.tar.bz2
nixlib-ca96b55d3a4a6b671ae841f1ad416f80f065bd63.tar.lz
nixlib-ca96b55d3a4a6b671ae841f1ad416f80f065bd63.tar.xz
nixlib-ca96b55d3a4a6b671ae841f1ad416f80f065bd63.tar.zst
nixlib-ca96b55d3a4a6b671ae841f1ad416f80f065bd63.zip
ruby_2_6: patch use-after-free
See https://bugs.ruby-lang.org/issues/16136.

This patch is on Ruby trunk, but hasn't been backported (yet?).
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/interpreters/ruby/default.nix6
-rw-r--r--pkgs/development/interpreters/ruby/patchsets.nix9
2 files changed, 10 insertions, 5 deletions
diff --git a/pkgs/development/interpreters/ruby/default.nix b/pkgs/development/interpreters/ruby/default.nix
index 19cc59619664..3494c8dee243 100644
--- a/pkgs/development/interpreters/ruby/default.nix
+++ b/pkgs/development/interpreters/ruby/default.nix
@@ -1,5 +1,5 @@
 { stdenv, buildPackages, lib
-, fetchurl, fetchFromSavannah, fetchFromGitHub
+, fetchurl, fetchpatch, fetchFromSavannah, fetchFromGitHub
 , zlib, openssl, gdbm, ncurses, readline, groff, libyaml, libffi, autoreconfHook, bison
 , autoconf, libiconv, libobjc, libunwind, Foundation
 , buildEnv, bundler, bundix
@@ -34,7 +34,7 @@ let
     };
     self = lib.makeOverridable (
       { stdenv, buildPackages, lib
-      , fetchurl, fetchFromSavannah, fetchFromGitHub
+      , fetchurl, fetchpatch, fetchFromSavannah, fetchFromGitHub
       , useRailsExpress ? true
       , rubygemsSupport ? true
       , zlib, zlibSupport ? true
@@ -90,7 +90,7 @@ let
 
         patches =
           (import ./patchsets.nix {
-            inherit patchSet useRailsExpress ops;
+            inherit patchSet useRailsExpress ops fetchpatch;
             patchLevel = ver.patchLevel;
           }).${ver.majMinTiny};
 
diff --git a/pkgs/development/interpreters/ruby/patchsets.nix b/pkgs/development/interpreters/ruby/patchsets.nix
index 62d8f53b3d3b..56164de5b5f2 100644
--- a/pkgs/development/interpreters/ruby/patchsets.nix
+++ b/pkgs/development/interpreters/ruby/patchsets.nix
@@ -1,4 +1,4 @@
-{ patchSet, useRailsExpress, ops, patchLevel }:
+{ patchSet, useRailsExpress, ops, patchLevel, fetchpatch }:
 
 {
   "2.3.8" = ops useRailsExpress [
@@ -16,7 +16,12 @@
     "${patchSet}/patches/ruby/2.5/head/railsexpress/02-improve-gc-stats.patch"
     "${patchSet}/patches/ruby/2.5/head/railsexpress/03-more-detailed-stacktrace.patch"
   ];
-  "2.6.4" = ops useRailsExpress [
+  "2.6.4" = [
+    (fetchpatch {
+      url = "https://git.ruby-lang.org/ruby.git/patch/?id=ade1283ca276f7d589ffd3539fbc7b9817f682d5";
+      sha256 = "1vgrckmzz0ykyxgzyp8fcifa93xz2hvyfil79bw1gc3xx94wnnxd";
+    })
+  ] ++ ops useRailsExpress [
     "${patchSet}/patches/ruby/2.6/head/railsexpress/01-fix-broken-tests-caused-by-ad.patch"
     "${patchSet}/patches/ruby/2.6/head/railsexpress/02-improve-gc-stats.patch"
     "${patchSet}/patches/ruby/2.6/head/railsexpress/03-more-detailed-stacktrace.patch"