about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorWill Dietz <w@wdtz.org>2019-07-05 21:29:09 -0500
committerMilan <me@pbb.lc>2020-04-18 02:00:04 +0200
commitca722c5e2bd661a0175296249ddad9e29acc7618 (patch)
tree22892950bdcfeb5b86f04b0484dc332ef56ad7e4 /pkgs/development
parent69e73264a92f9873a3c2c92b688fa5c26768f4d9 (diff)
downloadnixlib-ca722c5e2bd661a0175296249ddad9e29acc7618.tar
nixlib-ca722c5e2bd661a0175296249ddad9e29acc7618.tar.gz
nixlib-ca722c5e2bd661a0175296249ddad9e29acc7618.tar.bz2
nixlib-ca722c5e2bd661a0175296249ddad9e29acc7618.tar.lz
nixlib-ca722c5e2bd661a0175296249ddad9e29acc7618.tar.xz
nixlib-ca722c5e2bd661a0175296249ddad9e29acc7618.tar.zst
nixlib-ca722c5e2bd661a0175296249ddad9e29acc7618.zip
libtorrent-rasterbar: 1.1.11 -> 1.2.5
https://raw.githubusercontent.com/arvidn/libtorrent/libtorrent-1_2_5/ChangeLog

The old release is kept available as libtorrentRasterbar-1_1_x for deluge 1.x.
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/libraries/libtorrent-rasterbar/1.1/default.nix (renamed from pkgs/development/libraries/libtorrent-rasterbar/default.nix)6
-rw-r--r--pkgs/development/libraries/libtorrent-rasterbar/1.2/default.nix50
2 files changed, 52 insertions, 4 deletions
diff --git a/pkgs/development/libraries/libtorrent-rasterbar/default.nix b/pkgs/development/libraries/libtorrent-rasterbar/1.1/default.nix
index 26605eb41dbd..b2c958795f3e 100644
--- a/pkgs/development/libraries/libtorrent-rasterbar/default.nix
+++ b/pkgs/development/libraries/libtorrent-rasterbar/1.1/default.nix
@@ -1,5 +1,5 @@
 { stdenv, lib, fetchFromGitHub, pkgconfig, automake, autoconf
-, zlib, boost, openssl, libtool, python, libiconv, geoip, ncurses
+, zlib, boost, openssl, libtool, python, libiconv, ncurses
 }:
 
 let
@@ -23,7 +23,7 @@ in stdenv.mkDerivation {
 
   enableParallelBuilding = true;
   nativeBuildInputs = [ automake autoconf libtool pkgconfig ];
-  buildInputs = [ boostPython openssl zlib python libiconv geoip ncurses ];
+  buildInputs = [ boostPython openssl zlib python libiconv ncurses ];
   preConfigure = "./autotool.sh";
 
   postInstall = ''
@@ -35,11 +35,9 @@ in stdenv.mkDerivation {
 
   configureFlags = [
     "--enable-python-binding"
-    "--with-libgeoip=system"
     "--with-libiconv=yes"
     "--with-boost=${boostPython.dev}"
     "--with-boost-libdir=${boostPython.out}/lib"
-    "--with-libiconv=yes"
   ];
 
   meta = with stdenv.lib; {
diff --git a/pkgs/development/libraries/libtorrent-rasterbar/1.2/default.nix b/pkgs/development/libraries/libtorrent-rasterbar/1.2/default.nix
new file mode 100644
index 000000000000..8b9992ec66d4
--- /dev/null
+++ b/pkgs/development/libraries/libtorrent-rasterbar/1.2/default.nix
@@ -0,0 +1,50 @@
+{ stdenv, lib, fetchFromGitHub, pkgconfig, automake, autoconf
+, zlib, boost, openssl, libtool, python, libiconv, ncurses
+}:
+
+let
+  version = "1.2.5";
+  formattedVersion = lib.replaceChars ["."] ["_"] version;
+
+  # Make sure we override python, so the correct version is chosen
+  # for the bindings, if overridden
+  boostPython = boost.override { enablePython = true; inherit python; };
+
+in stdenv.mkDerivation {
+  pname = "libtorrent-rasterbar";
+  inherit version;
+
+  src = fetchFromGitHub {
+    owner = "arvidn";
+    repo = "libtorrent";
+    rev = "libtorrent-${formattedVersion}";
+    sha256 = "0y2fzqbvb1bxvf93d7sphwzxih6j40p5p3fay943k26w0nrq802w";
+  };
+
+  enableParallelBuilding = true;
+  nativeBuildInputs = [ automake autoconf libtool pkgconfig ];
+  buildInputs = [ boostPython openssl zlib python libiconv ncurses ];
+  preConfigure = "./autotool.sh";
+
+  postInstall = ''
+    moveToOutput "include" "$dev"
+    moveToOutput "lib/${python.libPrefix}" "$python"
+  '';
+
+  outputs = [ "out" "dev" "python" ];
+
+  configureFlags = [
+    "--enable-python-binding"
+    "--with-libiconv=yes"
+    "--with-boost=${boostPython.dev}"
+    "--with-boost-libdir=${boostPython.out}/lib"
+  ];
+
+  meta = with stdenv.lib; {
+    homepage = "https://libtorrent.org/";
+    description = "A C++ BitTorrent implementation focusing on efficiency and scalability";
+    license = licenses.bsd3;
+    maintainers = [ maintainers.phreedom ];
+    platforms = platforms.unix;
+  };
+}