about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorMatthieu Coudron <mattator@gmail.com>2019-09-26 15:56:32 +0900
committerMatthieu Coudron <mattator@gmail.com>2020-04-17 21:01:17 +0200
commitc881dd5e68731d3adb32e72614fa65082f59c743 (patch)
treef3ef658755b1039c291115c66009909bebd71700 /pkgs/development
parentc0a498b5d59f68f22677edf405247c883e5723d3 (diff)
downloadnixlib-c881dd5e68731d3adb32e72614fa65082f59c743.tar
nixlib-c881dd5e68731d3adb32e72614fa65082f59c743.tar.gz
nixlib-c881dd5e68731d3adb32e72614fa65082f59c743.tar.bz2
nixlib-c881dd5e68731d3adb32e72614fa65082f59c743.tar.lz
nixlib-c881dd5e68731d3adb32e72614fa65082f59c743.tar.xz
nixlib-c881dd5e68731d3adb32e72614fa65082f59c743.tar.zst
nixlib-c881dd5e68731d3adb32e72614fa65082f59c743.zip
pythonPackages.pagelabels: init at 1.2.0
Used in termpdf I want to package.
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/python-modules/pagelabels/default.nix23
1 files changed, 23 insertions, 0 deletions
diff --git a/pkgs/development/python-modules/pagelabels/default.nix b/pkgs/development/python-modules/pagelabels/default.nix
new file mode 100644
index 000000000000..d7adc9b17c04
--- /dev/null
+++ b/pkgs/development/python-modules/pagelabels/default.nix
@@ -0,0 +1,23 @@
+{ stdenv, buildPythonPackage, fetchPypi, pdfrw }:
+
+buildPythonPackage rec {
+  pname = "pagelabels";
+  version = "1.2.0";
+
+  src = fetchPypi {
+    inherit pname version;
+    sha256 = "07as5kzyvj66bfgvx8bph8gkyj6cgm4lhgxwb78bpdl4m8y8kpma";
+  };
+
+  buildInputs = [ pdfrw ];
+
+  # upstream doesn't contain tests
+  doCheck = false;
+
+  meta = with stdenv.lib; {
+    description = "Python library to manipulate PDF page labels.";
+    homepage = "https://github.com/lovasoa/pagelabels-py";
+    maintainers = with maintainers; [ teto ];
+    license = licenses.gpl3;
+  };
+}