about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorWilliam A. Kennington III <william@wkennington.com>2015-08-30 18:13:58 -0700
committerWilliam A. Kennington III <william@wkennington.com>2015-08-30 18:13:58 -0700
commitc6d73dcbb0d568c04e740e85a8b0e6372789f1ca (patch)
treeac18f38a8154d1db75d50048e4bedaae00433adc /pkgs/development
parentafe1f0f12706f68d3b8363a0c765d4fecad5c690 (diff)
downloadnixlib-c6d73dcbb0d568c04e740e85a8b0e6372789f1ca.tar
nixlib-c6d73dcbb0d568c04e740e85a8b0e6372789f1ca.tar.gz
nixlib-c6d73dcbb0d568c04e740e85a8b0e6372789f1ca.tar.bz2
nixlib-c6d73dcbb0d568c04e740e85a8b0e6372789f1ca.tar.lz
nixlib-c6d73dcbb0d568c04e740e85a8b0e6372789f1ca.tar.xz
nixlib-c6d73dcbb0d568c04e740e85a8b0e6372789f1ca.tar.zst
nixlib-c6d73dcbb0d568c04e740e85a8b0e6372789f1ca.zip
boost: Add 1.59
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/libraries/boost/1.59.nix40
1 files changed, 40 insertions, 0 deletions
diff --git a/pkgs/development/libraries/boost/1.59.nix b/pkgs/development/libraries/boost/1.59.nix
new file mode 100644
index 000000000000..2666b1d6c5d2
--- /dev/null
+++ b/pkgs/development/libraries/boost/1.59.nix
@@ -0,0 +1,40 @@
+{ stdenv, callPackage, fetchurl, ... } @ args:
+
+callPackage ./generic.nix (args // rec {
+  version = "1.59.0";
+
+  src = fetchurl {
+    url = "mirror://sourceforge/boost/boost_1_59_0.tar.bz2";
+    sha256 = "1jj1aai5rdmd72g90a3pd8sw9vi32zad46xv5av8fhnr48ir6ykj";
+  };
+
+  patches = if stdenv.isCygwin then [
+      ./cygwin-fedora-boost-1.50.0-fix-non-utf8-files.patch
+      ./cygwin-fedora-boost-1.50.0-pool.patch
+      ./cygwin-fedora-boost-1.57.0-mpl-print.patch
+      ./cygwin-fedora-boost-1.57.0-spirit-unused_typedef.patch
+      ./cygwin-fedora-boost-1.54.0-locale-unused_typedef.patch
+      ./cygwin-fedora-boost-1.54.0-python-unused_typedef.patch
+      ./cygwin-fedora-boost-1.57.0-pool-test_linking.patch
+      ./cygwin-fedora-boost-1.54.0-pool-max_chunks_shadow.patch
+      ./cygwin-fedora-boost-1.57.0-signals2-weak_ptr.patch
+      ./cygwin-fedora-boost-1.57.0-uuid-comparison.patch
+      ./cygwin-fedora-boost-1.57.0-move-is_class.patch
+      ./cygwin-1.40.0-cstdint-cygwin.patch
+      ./cygwin-1.57.0-asio-cygwin.patch
+      ./cygwin-1.55.0-asio-MSG_EOR.patch
+      ./cygwin-1.57.0-config-cygwin.patch
+      ./cygwin-1.57.0-context-cygwin.patch
+      ./cygwin-1.57.0-filesystem-cygwin.patch
+      ./cygwin-1.55.0-interlocked-cygwin.patch
+      ./cygwin-1.40.0-iostreams-cygwin.patch
+      ./cygwin-1.57.0-locale-cygwin.patch
+      ./cygwin-1.57.0-log-cygwin.patch
+      ./cygwin-1.40.0-python-cygwin.patch
+      ./cygwin-1.40.0-regex-cygwin.patch
+      ./cygwin-1.57.0-smart_ptr-cygwin.patch
+      ./cygwin-1.57.0-system-cygwin.patch
+      ./cygwin-1.45.0-jam-cygwin.patch
+      ./cygwin-1.50.0-jam-pep3149.patch
+    ] else null;
+})