about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorMartin Weinelt <hexa@darmstadt.ccc.de>2024-03-17 20:06:58 +0100
committerMartin Weinelt <hexa@darmstadt.ccc.de>2024-03-17 20:06:58 +0100
commitc4e3132698c136bb2e6c918c71f4a671a3aaf85b (patch)
tree44f999a1487ab12c580bd2cd4bb0272efb5db086 /pkgs/development
parentad9c358a6623c81000ec6818bf59922074516255 (diff)
downloadnixlib-c4e3132698c136bb2e6c918c71f4a671a3aaf85b.tar
nixlib-c4e3132698c136bb2e6c918c71f4a671a3aaf85b.tar.gz
nixlib-c4e3132698c136bb2e6c918c71f4a671a3aaf85b.tar.bz2
nixlib-c4e3132698c136bb2e6c918c71f4a671a3aaf85b.tar.lz
nixlib-c4e3132698c136bb2e6c918c71f4a671a3aaf85b.tar.xz
nixlib-c4e3132698c136bb2e6c918c71f4a671a3aaf85b.tar.zst
nixlib-c4e3132698c136bb2e6c918c71f4a671a3aaf85b.zip
python311Packages.intellifire4py: fix deps
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/python-modules/intellifire4py/default.nix6
1 files changed, 4 insertions, 2 deletions
diff --git a/pkgs/development/python-modules/intellifire4py/default.nix b/pkgs/development/python-modules/intellifire4py/default.nix
index 8eb75ec20bf7..bdbf149b3755 100644
--- a/pkgs/development/python-modules/intellifire4py/default.nix
+++ b/pkgs/development/python-modules/intellifire4py/default.nix
@@ -2,7 +2,8 @@
 , aenum
 , buildPythonPackage
 , fetchFromGitHub
-, httpx
+, aiohttp
+, aioresponses
 , poetry-core
 , pydantic
 , pytest-asyncio
@@ -31,13 +32,14 @@ buildPythonPackage rec {
   ];
 
   propagatedBuildInputs = [
+    aiohttp
     aenum
-    httpx
     pydantic
     rich
   ];
 
   nativeCheckInputs = [
+    aioresponses
     pytest-asyncio
     pytest-httpx
     pytestCheckHook