about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorrnhmjoj <rnhmjoj@inventati.org>2020-02-21 12:53:08 +0100
committerrnhmjoj <rnhmjoj@inventati.org>2020-02-21 13:40:24 +0100
commitc4865b8933b53ea7eb48637aff33f43a09e0eab8 (patch)
tree102f8214b3dac56a220cf4d1d5c68fcaa47d5aa0 /pkgs/development
parent7429153cacec508ff4f74cba8d79ac46ca61fba9 (diff)
downloadnixlib-c4865b8933b53ea7eb48637aff33f43a09e0eab8.tar
nixlib-c4865b8933b53ea7eb48637aff33f43a09e0eab8.tar.gz
nixlib-c4865b8933b53ea7eb48637aff33f43a09e0eab8.tar.bz2
nixlib-c4865b8933b53ea7eb48637aff33f43a09e0eab8.tar.lz
nixlib-c4865b8933b53ea7eb48637aff33f43a09e0eab8.tar.xz
nixlib-c4865b8933b53ea7eb48637aff33f43a09e0eab8.tar.zst
nixlib-c4865b8933b53ea7eb48637aff33f43a09e0eab8.zip
pythonPackages.pytest-timeout: disable flaky test
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/python-modules/pytest-timeout/default.nix5
1 files changed, 4 insertions, 1 deletions
diff --git a/pkgs/development/python-modules/pytest-timeout/default.nix b/pkgs/development/python-modules/pytest-timeout/default.nix
index 3997e716817f..3849fffd47c0 100644
--- a/pkgs/development/python-modules/pytest-timeout/default.nix
+++ b/pkgs/development/python-modules/pytest-timeout/default.nix
@@ -21,7 +21,10 @@ buildPythonPackage rec {
   };
 
   checkInputs = [ pytest pexpect ];
-  checkPhase = ''pytest -ra'';
+  checkPhase = ''
+    # test_suppresses_timeout_when_pdb_is_entered fails under heavy load
+    pytest -ra -k 'not test_suppresses_timeout_when_pdb_is_entered'
+  '';
 
   meta = with lib;{
     description = "py.test plugin to abort hanging tests";