about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
author(cdep)illabout <cdep.illabout@gmail.com>2020-02-13 10:23:23 +0900
committerPeter Simons <simons@cryp.to>2020-02-28 20:31:22 +0100
commitc44ded75fe48faa227083cfb9d7477b2bf73007e (patch)
treeee06780fd957905fecc93168fdbdb2c1e4918eec /pkgs/development
parenta0171c64394b279dd2971eec11d0f46f30cc8aa4 (diff)
downloadnixlib-c44ded75fe48faa227083cfb9d7477b2bf73007e.tar
nixlib-c44ded75fe48faa227083cfb9d7477b2bf73007e.tar.gz
nixlib-c44ded75fe48faa227083cfb9d7477b2bf73007e.tar.bz2
nixlib-c44ded75fe48faa227083cfb9d7477b2bf73007e.tar.lz
nixlib-c44ded75fe48faa227083cfb9d7477b2bf73007e.tar.xz
nixlib-c44ded75fe48faa227083cfb9d7477b2bf73007e.tar.zst
nixlib-c44ded75fe48faa227083cfb9d7477b2bf73007e.zip
haskellPackages.mplayer-spot: add runtime dependency on mplayer
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/haskell-modules/configuration-nix.nix9
1 files changed, 9 insertions, 0 deletions
diff --git a/pkgs/development/haskell-modules/configuration-nix.nix b/pkgs/development/haskell-modules/configuration-nix.nix
index 1c8775d6ca40..c1b1c22d5543 100644
--- a/pkgs/development/haskell-modules/configuration-nix.nix
+++ b/pkgs/development/haskell-modules/configuration-nix.nix
@@ -692,4 +692,13 @@ self: super: builtins.intersectAttrs super {
   # checks SQL statements at compile time, and so requires a running PostgreSQL
   # database to run it's test suite
   postgresql-typed = dontCheck super.postgresql-typed;
+
+  # mplayer-spot uses mplayer at runtime.
+  mplayer-spot =
+    let path = pkgs.stdenv.lib.makeBinPath [ pkgs.mplayer ];
+    in overrideCabal (addBuildTool super.mplayer-spot pkgs.makeWrapper) (oldAttrs: {
+      postInstall = ''
+        wrapProgram $out/bin/mplayer-spot --prefix PATH : "${path}"
+      '';
+    });
 }