about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorRenato Alves <alves.rjc@gmail.com>2020-02-17 16:22:13 +0100
committerRenato Alves <alves.rjc@gmail.com>2020-02-21 10:12:32 +0100
commitbf88bf47d1976b396fb06c5e608bb68e879e6952 (patch)
treee66c53aba05e43d84e4d764ec6e5f96b6602f86f /pkgs/development
parent0591e947571ccb8fec02524c1e27de4bc858b8d9 (diff)
downloadnixlib-bf88bf47d1976b396fb06c5e608bb68e879e6952.tar
nixlib-bf88bf47d1976b396fb06c5e608bb68e879e6952.tar.gz
nixlib-bf88bf47d1976b396fb06c5e608bb68e879e6952.tar.bz2
nixlib-bf88bf47d1976b396fb06c5e608bb68e879e6952.tar.lz
nixlib-bf88bf47d1976b396fb06c5e608bb68e879e6952.tar.xz
nixlib-bf88bf47d1976b396fb06c5e608bb68e879e6952.tar.zst
nixlib-bf88bf47d1976b396fb06c5e608bb68e879e6952.zip
pysam: 0.15.3 -> 0.15.4
Also disable tests until upstream test data issues are resolved.
See link in comment in code for more information.
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/python-modules/pysam/default.nix27
1 files changed, 18 insertions, 9 deletions
diff --git a/pkgs/development/python-modules/pysam/default.nix b/pkgs/development/python-modules/pysam/default.nix
index 46dd54c62e20..38b55c4563da 100644
--- a/pkgs/development/python-modules/pysam/default.nix
+++ b/pkgs/development/python-modules/pysam/default.nix
@@ -14,7 +14,7 @@
 
 buildPythonPackage rec {
   pname   = "pysam";
-  version = "0.15.3";
+  version = "0.15.4";
 
   # Fetching from GitHub instead of PyPi cause the 0.13 src release on PyPi is
   # missing some files which cause test failures.
@@ -23,26 +23,35 @@ buildPythonPackage rec {
     owner = "pysam-developers";
     repo = "pysam";
     rev = "v${version}";
-    sha256 = "0g6md20gsr24pdr9b8nj403w31ixfjv8bjhdvg3x476kjiq1kvyb";
+    sha256 = "04w6h6mv6lsr74hj9gy4r2laifcbhgl2bjcr4r1l9r73xdd45mdy";
   };
 
+  nativeBuildInputs = [ samtools ];
   buildInputs = [ bzip2 curl cython lzma zlib ];
 
-  checkInputs = [ pytest bcftools htslib samtools ];
-
+  checkInputs = [ pytest bcftools htslib ];
   checkPhase = "py.test";
 
-  preInstall = ''
+  # tests require samtools<=1.9
+  doCheck = false;
+  preCheck = ''
     export HOME=$(mktemp -d)
     make -C tests/pysam_data
     make -C tests/cbcf_data
   '';
 
-  meta = {
-    homepage = https://pysam.readthedocs.io/;
+  pythonImportsCheck = [
+    "pysam"
+    "pysam.bcftools"
+    "pysam.libcutils"
+    "pysam.libcvcf"
+  ];
+
+  meta = with lib; {
     description = "A python module for reading, manipulating and writing genome data sets";
-    maintainers = with lib.maintainers; [ unode ];
-    license = lib.licenses.mit;
+    homepage = "https://pysam.readthedocs.io/";
+    maintainers = with maintainers; [ unode ];
+    license = licenses.mit;
     platforms = [ "i686-linux" "x86_64-linux" ];
   };
 }