about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorJoachim Fasting <joachifm@fastmail.fm>2015-04-30 17:05:14 +0200
committerJoachim Fasting <joachifm@fastmail.fm>2015-04-30 18:17:42 +0200
commitbf7ad2d84fc8244a61fd65b69a2dda0640c54df1 (patch)
tree2b5773648e998a9a2484bcae479be4e8d26446ca /pkgs/development
parent6524f969e552168846fdd63e6f1b41e881dcb8fe (diff)
downloadnixlib-bf7ad2d84fc8244a61fd65b69a2dda0640c54df1.tar
nixlib-bf7ad2d84fc8244a61fd65b69a2dda0640c54df1.tar.gz
nixlib-bf7ad2d84fc8244a61fd65b69a2dda0640c54df1.tar.bz2
nixlib-bf7ad2d84fc8244a61fd65b69a2dda0640c54df1.tar.lz
nixlib-bf7ad2d84fc8244a61fd65b69a2dda0640c54df1.tar.xz
nixlib-bf7ad2d84fc8244a61fd65b69a2dda0640c54df1.tar.zst
nixlib-bf7ad2d84fc8244a61fd65b69a2dda0640c54df1.zip
meta.description fixups
Mostly scripted substitutions with a couple of subjective enhancements.
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/compilers/elm/elm-compiler.nix2
-rw-r--r--pkgs/development/compilers/ghcjs/default.nix2
-rw-r--r--pkgs/development/compilers/gwt/2.4.0.nix2
-rw-r--r--pkgs/development/compilers/scala/2.10.nix2
-rw-r--r--pkgs/development/compilers/scala/2.9.nix2
-rw-r--r--pkgs/development/compilers/yap/default.nix2
-rw-r--r--pkgs/development/coq-modules/bedrock/default.nix2
-rw-r--r--pkgs/development/coq-modules/fiat/default.nix2
-rw-r--r--pkgs/development/coq-modules/flocq/default.nix2
-rw-r--r--pkgs/development/coq-modules/paco/default.nix2
-rw-r--r--pkgs/development/coq-modules/tlc/default.nix2
-rw-r--r--pkgs/development/coq-modules/ynot/default.nix2
-rw-r--r--pkgs/development/libraries/assimp/default.nix2
-rw-r--r--pkgs/development/libraries/fcgi/default.nix2
-rw-r--r--pkgs/development/libraries/fox/fox-1.6.nix2
-rw-r--r--pkgs/development/libraries/giflib/5.0.nix2
-rw-r--r--pkgs/development/libraries/giflib/5.1.nix2
-rw-r--r--pkgs/development/libraries/lame/default.nix2
-rw-r--r--pkgs/development/libraries/libtomcrypt/default.nix2
-rw-r--r--pkgs/development/libraries/npapi-sdk/default.nix2
-rw-r--r--pkgs/development/libraries/physics/geant4/default.nix4
-rw-r--r--pkgs/development/libraries/physics/geant4/g4py/default.nix2
-rw-r--r--pkgs/development/libraries/qmltermwidget/default.nix2
-rw-r--r--pkgs/development/libraries/urt/default.nix2
-rw-r--r--pkgs/development/lisp-modules/lisp-packages.nix2
-rw-r--r--pkgs/development/ocaml-modules/gmetadom/default.nix2
-rw-r--r--pkgs/development/ocaml-modules/ocaml-text/default.nix2
-rw-r--r--pkgs/development/ocaml-modules/ulex/0.8/default.nix2
-rw-r--r--pkgs/development/ocaml-modules/ulex/default.nix2
-rw-r--r--pkgs/development/tools/misc/checkbashisms/default.nix2
-rw-r--r--pkgs/development/tools/ocaml/camlidl/default.nix2
-rw-r--r--pkgs/development/tools/parsing/hammer/default.nix16
32 files changed, 41 insertions, 39 deletions
diff --git a/pkgs/development/compilers/elm/elm-compiler.nix b/pkgs/development/compilers/elm/elm-compiler.nix
index 87a0b660d2ad..9cf8eda2d9a3 100644
--- a/pkgs/development/compilers/elm/elm-compiler.nix
+++ b/pkgs/development/compilers/elm/elm-compiler.nix
@@ -27,7 +27,7 @@ cabal.mkDerivation (self: {
   ];
   meta = {
     homepage = "http://elm-lang.org";
-    description = "Values to help with elm-package, elm-make, and elm-lang.org.";
+    description = "Values to help with elm-package, elm-make, and elm-lang.org";
     license = self.stdenv.lib.licenses.bsd3;
     platforms = self.ghc.meta.platforms;
   };
diff --git a/pkgs/development/compilers/ghcjs/default.nix b/pkgs/development/compilers/ghcjs/default.nix
index 8206bb19e4fa..54604f548fa7 100644
--- a/pkgs/development/compilers/ghcjs/default.nix
+++ b/pkgs/development/compilers/ghcjs/default.nix
@@ -122,7 +122,7 @@ in mkDerivation (rec {
   };
 
   homepage = "https://github.com/ghcjs/ghcjs";
-  description = "GHCJS is a Haskell to JavaScript compiler that uses the GHC API";
+  description = "A Haskell to JavaScript compiler that uses the GHC API";
   license = stdenv.lib.licenses.bsd3;
   platforms = ghc.meta.platforms;
   maintainers = with stdenv.lib.maintainers; [ jwiegley cstrahan ];
diff --git a/pkgs/development/compilers/gwt/2.4.0.nix b/pkgs/development/compilers/gwt/2.4.0.nix
index f0dc9378c4f0..588861ee42de 100644
--- a/pkgs/development/compilers/gwt/2.4.0.nix
+++ b/pkgs/development/compilers/gwt/2.4.0.nix
@@ -18,6 +18,6 @@ stdenv.mkDerivation {
 
   meta = {
     homepage = http://code.google.com/webtoolkit/;
-    description = "Google Web Toolkit (GWT) is a development toolkit for building and optimizing complex browser-based applications";
+    description = "A development toolkit for building and optimizing complex browser-based applications";
   };
 }
diff --git a/pkgs/development/compilers/scala/2.10.nix b/pkgs/development/compilers/scala/2.10.nix
index b518a9a0e0ec..ab13e0ba7dc3 100644
--- a/pkgs/development/compilers/scala/2.10.nix
+++ b/pkgs/development/compilers/scala/2.10.nix
@@ -21,7 +21,7 @@ stdenv.mkDerivation rec {
   '';
 
   meta = {
-    description = "Scala is a general purpose programming language";
+    description = "A general purpose programming language";
     longDescription = ''
       Scala is a general purpose programming language designed to express
       common programming patterns in a concise, elegant, and type-safe way.
diff --git a/pkgs/development/compilers/scala/2.9.nix b/pkgs/development/compilers/scala/2.9.nix
index de5db1eff996..c98e2e75c171 100644
--- a/pkgs/development/compilers/scala/2.9.nix
+++ b/pkgs/development/compilers/scala/2.9.nix
@@ -18,7 +18,7 @@ stdenv.mkDerivation rec {
   '';
 
   meta = {
-    description = "Scala is a general purpose programming language";
+    description = "A general purpose programming language";
     longDescription = ''
       Scala is a general purpose programming language designed to express
       common programming patterns in a concise, elegant, and type-safe way.
diff --git a/pkgs/development/compilers/yap/default.nix b/pkgs/development/compilers/yap/default.nix
index f9b587c05049..2482f2ac1316 100644
--- a/pkgs/development/compilers/yap/default.nix
+++ b/pkgs/development/compilers/yap/default.nix
@@ -15,7 +15,7 @@ stdenv.mkDerivation rec {
 
   meta = {
     homepage = "http://www.dcc.fc.up.pt/~vsc/Yap/";
-    description = "Yap Prolog System is a ISO-compatible high-performance Prolog compiler";
+    description = "A ISO-compatible high-performance Prolog compiler";
     license = stdenv.lib.licenses.artistic2;
 
     maintainers = [ stdenv.lib.maintainers.simons ];
diff --git a/pkgs/development/coq-modules/bedrock/default.nix b/pkgs/development/coq-modules/bedrock/default.nix
index 478f74058bdf..92a3d16963b6 100644
--- a/pkgs/development/coq-modules/bedrock/default.nix
+++ b/pkgs/development/coq-modules/bedrock/default.nix
@@ -28,7 +28,7 @@ stdenv.mkDerivation rec {
 
   meta = with stdenv.lib; {
     homepage = http://plv.csail.mit.edu/bedrock/;
-    description = "Bedrock is a library that turns Coq into a tool much like classical verification systems";
+    description = "A library that turns Coq into a tool much like classical verification systems";
     maintainers = with maintainers; [ jwiegley ];
     platforms = coq.meta.platforms;
   };
diff --git a/pkgs/development/coq-modules/fiat/default.nix b/pkgs/development/coq-modules/fiat/default.nix
index 9f020de15345..92b69319e0bc 100644
--- a/pkgs/development/coq-modules/fiat/default.nix
+++ b/pkgs/development/coq-modules/fiat/default.nix
@@ -33,7 +33,7 @@ stdenv.mkDerivation rec {
 
   meta = with stdenv.lib; {
     homepage = http://plv.csail.mit.edu/fiat/;
-    description = "Fiat is a library for the Coq proof assistant for synthesizing efficient correct-by-construction programs from declarative specifications";
+    description = "A library for the Coq proof assistant for synthesizing efficient correct-by-construction programs from declarative specifications";
     maintainers = with maintainers; [ jwiegley ];
     platforms = coq.meta.platforms;
   };
diff --git a/pkgs/development/coq-modules/flocq/default.nix b/pkgs/development/coq-modules/flocq/default.nix
index 89555c2e13da..05267d6bf6c2 100644
--- a/pkgs/development/coq-modules/flocq/default.nix
+++ b/pkgs/development/coq-modules/flocq/default.nix
@@ -25,7 +25,7 @@ stdenv.mkDerivation rec {
 
   meta = with stdenv.lib; {
     homepage = http://flocq.gforge.inria.fr/;
-    description = "Flocq (Floats for Coq) is a floating-point formalization for the Coq system";
+    description = "A floating-point formalization for the Coq system";
     license = licenses.lgpl3;
     maintainers = with maintainers; [ jwiegley ];
     platforms = coq.meta.platforms;
diff --git a/pkgs/development/coq-modules/paco/default.nix b/pkgs/development/coq-modules/paco/default.nix
index c885d14aa3f2..98d447d21d38 100644
--- a/pkgs/development/coq-modules/paco/default.nix
+++ b/pkgs/development/coq-modules/paco/default.nix
@@ -23,7 +23,7 @@ stdenv.mkDerivation rec {
 
   meta = with stdenv.lib; {
     homepage = http://plv.mpi-sws.org/paco/;
-    description = "Paco is a Coq library implementing parameterized coinduction";
+    description = "A Coq library implementing parameterized coinduction";
     maintainers = with maintainers; [ jwiegley ];
     platforms = coq.meta.platforms;
   };
diff --git a/pkgs/development/coq-modules/tlc/default.nix b/pkgs/development/coq-modules/tlc/default.nix
index e47ffbdd4562..b98ff613f9d9 100644
--- a/pkgs/development/coq-modules/tlc/default.nix
+++ b/pkgs/development/coq-modules/tlc/default.nix
@@ -21,7 +21,7 @@ stdenv.mkDerivation {
 
   meta = with stdenv.lib; {
     homepage = http://www.chargueraud.org/softs/tlc/;
-    description = "TLC is a general purpose Coq library that provides an alternative to Coq's standard library";
+    description = "A general purpose Coq library that provides an alternative to Coq's standard library";
     maintainers = with maintainers; [ jwiegley ];
     platforms = coq.meta.platforms;
   };
diff --git a/pkgs/development/coq-modules/ynot/default.nix b/pkgs/development/coq-modules/ynot/default.nix
index 555945068b1a..d83e2c5c7909 100644
--- a/pkgs/development/coq-modules/ynot/default.nix
+++ b/pkgs/development/coq-modules/ynot/default.nix
@@ -24,7 +24,7 @@ stdenv.mkDerivation rec {
 
   meta = with stdenv.lib; {
     homepage = http://ynot.cs.harvard.edu/;
-    description = "Ynot is a library for writing and verifying imperative programs";
+    description = "A library for writing and verifying imperative programs";
     maintainers = with maintainers; [ jwiegley ];
     platforms = coq.meta.platforms;
   };
diff --git a/pkgs/development/libraries/assimp/default.nix b/pkgs/development/libraries/assimp/default.nix
index 229db910ffd2..70447d9f8853 100644
--- a/pkgs/development/libraries/assimp/default.nix
+++ b/pkgs/development/libraries/assimp/default.nix
@@ -17,7 +17,7 @@ stdenv.mkDerivation {
   buildInputs = [ unzip cmake boost ];
 
   meta = with stdenv.lib; {
-    description = "Open Asset Import Library is a library to import various 3D model formats";
+    description = "A library to import various 3D model formats";
     homepage = http://assimp.sourceforge.net/;
     license = licenses.bsd3;
     maintainers = with maintainers; [ emery ];
diff --git a/pkgs/development/libraries/fcgi/default.nix b/pkgs/development/libraries/fcgi/default.nix
index f75c21170840..6808ea52adff 100644
--- a/pkgs/development/libraries/fcgi/default.nix
+++ b/pkgs/development/libraries/fcgi/default.nix
@@ -13,7 +13,7 @@ stdenv.mkDerivation rec {
   postInstall = "ln -s . $out/include/fastcgi";
 
   meta = with stdenv.lib; {
-    description = "FastCGI  is a language independent, scalable, open extension to CG";
+    description = "A language independent, scalable, open extension to CG";
     homepage = http://www.fastcgi.com/;
     license = "FastCGI see LICENSE.TERMS";
     platforms = platforms.all;
diff --git a/pkgs/development/libraries/fox/fox-1.6.nix b/pkgs/development/libraries/fox/fox-1.6.nix
index 604fe3c2fdf0..e966388b2ad9 100644
--- a/pkgs/development/libraries/fox/fox-1.6.nix
+++ b/pkgs/development/libraries/fox/fox-1.6.nix
@@ -22,7 +22,7 @@ stdenv.mkDerivation rec {
 
   meta = {
     branch = "1.6";
-    description = "FOX is a C++ based class library for building Graphical User Interfaces";
+    description = "A C++ based class library for building Graphical User Interfaces";
     longDescription = ''
         FOX stands for Free Objects for X.
         It is a C++ based class library for building Graphical User Interfaces.
diff --git a/pkgs/development/libraries/giflib/5.0.nix b/pkgs/development/libraries/giflib/5.0.nix
index 49e3fc40ba66..95038284cd60 100644
--- a/pkgs/development/libraries/giflib/5.0.nix
+++ b/pkgs/development/libraries/giflib/5.0.nix
@@ -9,7 +9,7 @@ stdenv.mkDerivation {
 
   buildInputs = [ xmlto docbook_xml_dtd_412 docbook_xsl libxml2 ];
   meta = {
-    description = "giflib is a library for reading and writing gif images";
+    description = "A library for reading and writing gif images";
     platforms = stdenv.lib.platforms.unix;
     license = stdenv.lib.licenses.mit;
     maintainers = with stdenv.lib.maintainers; [ fuuzetsu ];
diff --git a/pkgs/development/libraries/giflib/5.1.nix b/pkgs/development/libraries/giflib/5.1.nix
index dcd52fc93f46..0bccb857d350 100644
--- a/pkgs/development/libraries/giflib/5.1.nix
+++ b/pkgs/development/libraries/giflib/5.1.nix
@@ -9,7 +9,7 @@ stdenv.mkDerivation {
 
   buildInputs = [ xmlto docbook_xml_dtd_412 docbook_xsl libxml2 ];
   meta = {
-    description = "giflib is a library for reading and writing gif images";
+    description = "A library for reading and writing gif images";
     platforms = stdenv.lib.platforms.unix;
     license = stdenv.lib.licenses.mit;
     maintainers = with stdenv.lib.maintainers; [ fuuzetsu ];
diff --git a/pkgs/development/libraries/lame/default.nix b/pkgs/development/libraries/lame/default.nix
index abf05f4c1385..562e292791ab 100644
--- a/pkgs/development/libraries/lame/default.nix
+++ b/pkgs/development/libraries/lame/default.nix
@@ -53,7 +53,7 @@ stdenv.mkDerivation rec {
   ];
 
   meta = {
-    description = "LAME is a high quality MPEG Audio Layer III (MP3) encoder";
+    description = "A high quality MPEG Audio Layer III (MP3) encoder";
     homepage    = http://lame.sourceforge.net;
     license     = licenses.lgpl2;
     maintainers = with maintainers; [ codyopel ];
diff --git a/pkgs/development/libraries/libtomcrypt/default.nix b/pkgs/development/libraries/libtomcrypt/default.nix
index 4a3196e44b88..e960f5ef57f3 100644
--- a/pkgs/development/libraries/libtomcrypt/default.nix
+++ b/pkgs/development/libraries/libtomcrypt/default.nix
@@ -21,6 +21,6 @@ stdenv.mkDerivation {
 
   meta = {
     homepage = "http://libtom.org/?page=features&newsitems=5&whatfile=crypt";
-    description = "LibTomCrypt is a fairly comprehensive, modular and portable cryptographic toolkit";
+    description = "A fairly comprehensive, modular and portable cryptographic toolkit";
   };
 }
diff --git a/pkgs/development/libraries/npapi-sdk/default.nix b/pkgs/development/libraries/npapi-sdk/default.nix
index 57b1b3af2d1c..c2799d039cc1 100644
--- a/pkgs/development/libraries/npapi-sdk/default.nix
+++ b/pkgs/development/libraries/npapi-sdk/default.nix
@@ -12,7 +12,7 @@ stdenv.mkDerivation rec {
   };
 
   meta = with stdenv.lib; {
-    description = "NPAPI-SDK is a bundle of NPAPI headers by Mozilla";
+    description = "A bundle of NPAPI headers by Mozilla";
 
     homepage = https://code.google.com/p/npapi-sdk/;
     license = licenses.bsd3;
diff --git a/pkgs/development/libraries/physics/geant4/default.nix b/pkgs/development/libraries/physics/geant4/default.nix
index 1e1fc7ea3b8f..872576d9fb02 100644
--- a/pkgs/development/libraries/physics/geant4/default.nix
+++ b/pkgs/development/libraries/physics/geant4/default.nix
@@ -92,7 +92,7 @@ let
       '';
 
       meta = {
-        description = "A toolkit for the simulation of the passage of particles through matter.";
+        description = "A toolkit for the simulation of the passage of particles through matter";
         longDescription = ''
           Geant4 is a toolkit for the simulation of the passage of particles through matter.
           Its areas of application include high energy, nuclear and accelerator physics, as well as studies in medical and space science.
@@ -129,7 +129,7 @@ let
       '';
 
       meta = {
-        description = "Data files for the Geant4 toolkit.";
+        description = "Data files for the Geant4 toolkit";
         homepage = http://www.geant4.org;
         license = stdenv.lib.licenses.g4sl;
         maintainers = [ ];
diff --git a/pkgs/development/libraries/physics/geant4/g4py/default.nix b/pkgs/development/libraries/physics/geant4/g4py/default.nix
index f90b2e6c4aee..e023b1220910 100644
--- a/pkgs/development/libraries/physics/geant4/g4py/default.nix
+++ b/pkgs/development/libraries/physics/geant4/g4py/default.nix
@@ -45,7 +45,7 @@ let
       '';
 
       meta = {
-        description = "Python bindings and utilities for Geant4.";
+        description = "Python bindings and utilities for Geant4";
         longDescription = ''
           Geant4 is a toolkit for the simulation of the passage of particles through matter.      
           Its areas of application include high energy, nuclear and accelerator physics, as well as studies in medical and space science.
diff --git a/pkgs/development/libraries/qmltermwidget/default.nix b/pkgs/development/libraries/qmltermwidget/default.nix
index d011114bfd20..9078796fee62 100644
--- a/pkgs/development/libraries/qmltermwidget/default.nix
+++ b/pkgs/development/libraries/qmltermwidget/default.nix
@@ -24,7 +24,7 @@ stdenv.mkDerivation rec {
   enableParallelBuilding = true;
 
   meta = {
-    description = "This project is a QML port of qtermwidget";
+    description = "A QML port of qtermwidget";
     homepage = "https://github.com/Swordifish90/qmltermwidget";
     license = with stdenv.lib.licenses; [ gpl2 ];
     platforms = stdenv.lib.platforms.linux;
diff --git a/pkgs/development/libraries/urt/default.nix b/pkgs/development/libraries/urt/default.nix
index 8570af2b2834..090ca28d7c45 100644
--- a/pkgs/development/libraries/urt/default.nix
+++ b/pkgs/development/libraries/urt/default.nix
@@ -56,6 +56,6 @@ stdenv.mkDerivation rec {
 
   meta = {
     homepage = http://www.cs.utah.edu/gdc/projects/urt/;
-    description = "The Utah Raster Toolkit is a library for dealing with raster images";
+    description = "A library for dealing with raster images";
   };
 }
\ No newline at end of file
diff --git a/pkgs/development/lisp-modules/lisp-packages.nix b/pkgs/development/lisp-modules/lisp-packages.nix
index d7bd2348244e..7d4c88e5c9e0 100644
--- a/pkgs/development/lisp-modules/lisp-packages.nix
+++ b/pkgs/development/lisp-modules/lisp-packages.nix
@@ -98,7 +98,7 @@ let lispPackages = rec {
   clx-truetype = buildLispPackage rec {
     baseName = "clx-truetype";
     version = "git-20141112";
-    description = "clx-truetype is pure common lisp solution for antialiased TrueType font rendering using CLX and XRender extension";
+    description = "A pure Common Lisp solution for antialiased TrueType font rendering using CLX and the XRender extension";
     deps = [cl-fad cl-store cl-vectors clx trivial-features zpb-ttf];
     # Source type: git
     src = pkgs.fetchgit {
diff --git a/pkgs/development/ocaml-modules/gmetadom/default.nix b/pkgs/development/ocaml-modules/gmetadom/default.nix
index f1ec69143b07..f0a9387a537e 100644
--- a/pkgs/development/ocaml-modules/gmetadom/default.nix
+++ b/pkgs/development/ocaml-modules/gmetadom/default.nix
@@ -29,7 +29,7 @@ stdenv.mkDerivation {
 
   meta = {
     homepage = http://gmetadom.sourceforge.net/;
-    description = "GMetaDOM is a collection of librares, each library providing a DOM implementation";
+    description = "A collection of librares, each library providing a DOM implementation";
     license = stdenv.lib.licenses.lgpl21Plus;
     maintainers = [ stdenv.lib.maintainers.roconnor ];
   };
diff --git a/pkgs/development/ocaml-modules/ocaml-text/default.nix b/pkgs/development/ocaml-modules/ocaml-text/default.nix
index 44b30b368b32..c82785e4aa94 100644
--- a/pkgs/development/ocaml-modules/ocaml-text/default.nix
+++ b/pkgs/development/ocaml-modules/ocaml-text/default.nix
@@ -17,7 +17,7 @@ stdenv.mkDerivation {
 
   meta = {
     homepage = "http://ocaml-text.forge.ocamlcore.org/";
-    description = "OCaml-Text is a library for dealing with ``text'', i.e. sequence of unicode characters, in a convenient way. ";
+    description = "A library for convenient text manipulation";
     license = stdenv.lib.licenses.bsd3;
     platforms = ocaml.meta.platforms;
   };
diff --git a/pkgs/development/ocaml-modules/ulex/0.8/default.nix b/pkgs/development/ocaml-modules/ulex/0.8/default.nix
index 77ffa7528981..eddc71aeace2 100644
--- a/pkgs/development/ocaml-modules/ulex/0.8/default.nix
+++ b/pkgs/development/ocaml-modules/ulex/0.8/default.nix
@@ -27,7 +27,7 @@ stdenv.mkDerivation {
 
   meta = {
     homepage = http://www.cduce.org/download.html;
-    description = "ulex is a lexer generator for Unicode and OCaml";
+    description = "A lexer generator for Unicode and OCaml";
     license = stdenv.lib.licenses.mit;
     maintainers = [ stdenv.lib.maintainers.roconnor ];
   };
diff --git a/pkgs/development/ocaml-modules/ulex/default.nix b/pkgs/development/ocaml-modules/ulex/default.nix
index 123641ba1ac0..28950078f39e 100644
--- a/pkgs/development/ocaml-modules/ulex/default.nix
+++ b/pkgs/development/ocaml-modules/ulex/default.nix
@@ -23,7 +23,7 @@ stdenv.mkDerivation {
 
   meta = {
     homepage = http://www.cduce.org/download.html;
-    description = "ulex is a lexer generator for Unicode and OCaml";
+    description = "A lexer generator for Unicode and OCaml";
     license = stdenv.lib.licenses.mit;
     platforms = stdenv.lib.platforms.linux;
     maintainers = [ stdenv.lib.maintainers.roconnor ];
diff --git a/pkgs/development/tools/misc/checkbashisms/default.nix b/pkgs/development/tools/misc/checkbashisms/default.nix
index 9c48227c9a83..1585b126961b 100644
--- a/pkgs/development/tools/misc/checkbashisms/default.nix
+++ b/pkgs/development/tools/misc/checkbashisms/default.nix
@@ -12,7 +12,7 @@ stdenv.mkDerivation rec {
 
   meta = {
     homepage = http://sourceforge.net/projects/checkbaskisms/;
-    description = "Performs basic checks on shell scripts for the presence of non portable syntax";
+    description = "Check shell scripts for non-portable syntax";
     license = stdenv.lib.licenses.gpl2;
   };
 
diff --git a/pkgs/development/tools/ocaml/camlidl/default.nix b/pkgs/development/tools/ocaml/camlidl/default.nix
index dee605ced570..7a980c69c183 100644
--- a/pkgs/development/tools/ocaml/camlidl/default.nix
+++ b/pkgs/development/tools/ocaml/camlidl/default.nix
@@ -37,7 +37,7 @@ stdenv.mkDerivation {
   '';
 
   meta = {
-    description = "CamlIDL is a stub code generator and COM binding for Objective Caml";
+    description = "A stub code generator and COM binding for Objective Caml";
     homepage = "${webpage}";
     license = "LGPL";
     maintainers = [ stdenv.lib.maintainers.roconnor ];
diff --git a/pkgs/development/tools/parsing/hammer/default.nix b/pkgs/development/tools/parsing/hammer/default.nix
index f04d773c374b..5392f14926b8 100644
--- a/pkgs/development/tools/parsing/hammer/default.nix
+++ b/pkgs/development/tools/parsing/hammer/default.nix
@@ -15,13 +15,15 @@ stdenv.mkDerivation rec {
   installPhase = "scons prefix=$out install";
 
   meta = with stdenv.lib; {
-    description = "Hammer is a parsing library";
-    longDescription = "Hammer is a parsing library. Like many modern parsing libraries,
-	       it provides a parser combinator interface for writing grammars
-	       as inline domain-specific languages, but Hammer also provides a
-	       variety of parsing backends. It's also bit-oriented rather than
-	       character-oriented, making it ideal for parsing binary data such
-	       as images, network packets, audio, and executables.";
+    description = "A bit-oriented parser combinator library";
+    longDescription = ''
+      Hammer is a parsing library. Like many modern parsing libraries,
+      it provides a parser combinator interface for writing grammars
+      as inline domain-specific languages, but Hammer also provides a
+      variety of parsing backends. It's also bit-oriented rather than
+      character-oriented, making it ideal for parsing binary data such
+      as images, network packets, audio, and executables.
+    '';
     homepage = https://github.com/UpstandingHackers/hammer;
     license = licenses.gpl2;
     platforms = platforms.linux;