about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorTimo Kaufmann <timokau@zoho.com>2020-01-06 17:12:34 +0100
committerGitHub <noreply@github.com>2020-01-06 17:12:34 +0100
commitbdbec903046bd6f05cacdf443a25943b17ced7f5 (patch)
treed3e7239b55e62f26f640594cb815e637c56861fd /pkgs/development
parentc496b1b102457d0d7403a200087e4d3b5de0280c (diff)
parent9a982d3540497203632516616109459911129675 (diff)
downloadnixlib-bdbec903046bd6f05cacdf443a25943b17ced7f5.tar
nixlib-bdbec903046bd6f05cacdf443a25943b17ced7f5.tar.gz
nixlib-bdbec903046bd6f05cacdf443a25943b17ced7f5.tar.bz2
nixlib-bdbec903046bd6f05cacdf443a25943b17ced7f5.tar.lz
nixlib-bdbec903046bd6f05cacdf443a25943b17ced7f5.tar.xz
nixlib-bdbec903046bd6f05cacdf443a25943b17ced7f5.tar.zst
nixlib-bdbec903046bd6f05cacdf443a25943b17ced7f5.zip
Merge pull request #76945 from prusnak/tensorflow-drop-bin2c-path
python.pkgs.tensorflow: fix build with cudatoolkit 10.2
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/python-modules/tensorflow/cuda-10.2-no-bin2c-path.patch10
-rw-r--r--pkgs/development/python-modules/tensorflow/default.nix4
2 files changed, 14 insertions, 0 deletions
diff --git a/pkgs/development/python-modules/tensorflow/cuda-10.2-no-bin2c-path.patch b/pkgs/development/python-modules/tensorflow/cuda-10.2-no-bin2c-path.patch
new file mode 100644
index 000000000000..25f1ba7a5518
--- /dev/null
+++ b/pkgs/development/python-modules/tensorflow/cuda-10.2-no-bin2c-path.patch
@@ -0,0 +1,10 @@
+--- a/third_party/nccl/build_defs.bzl.tpl
++++ b/third_party/nccl/build_defs.bzl.tpl
+@@ -113,7 +113,6 @@ def _device_link_impl(ctx):
+             "--cmdline=--compile-only",
+             "--link",
+             "--compress-all",
+-            "--bin2c-path=%s" % bin2c.dirname,
+             "--create=%s" % tmp_fatbin.path,
+             "--embedded-fatbin=%s" % fatbin_h.path,
+         ] + images,
diff --git a/pkgs/development/python-modules/tensorflow/default.nix b/pkgs/development/python-modules/tensorflow/default.nix
index 34282a5ec937..a9f3ebf9e486 100644
--- a/pkgs/development/python-modules/tensorflow/default.nix
+++ b/pkgs/development/python-modules/tensorflow/default.nix
@@ -124,6 +124,10 @@ let
         sha256 = "077cpj0kzyqxzdya1dwh8df17zfzhqn7c685hx6iskvw2979zg2n";
       })
       ./lift-gast-restriction.patch
+
+      # cuda 10.2 does not have "-bin2c-path" option anymore
+      # https://github.com/tensorflow/tensorflow/issues/34429
+      ./cuda-10.2-no-bin2c-path.patch
     ];
 
     # On update, it can be useful to steal the changes from gentoo