about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorAndres Löh <mail@andres-loeh.de>2011-09-09 20:45:04 +0000
committerAndres Löh <mail@andres-loeh.de>2011-09-09 20:45:04 +0000
commitbc3c074cb858cf82cde42212ebf66b06d3c9e370 (patch)
treea7fda4ec5e4a9dccbe0478ac69da715f1edb78fd /pkgs/development
parent4e6013e90962a6638802f0b628898e8a7a462139 (diff)
downloadnixlib-bc3c074cb858cf82cde42212ebf66b06d3c9e370.tar
nixlib-bc3c074cb858cf82cde42212ebf66b06d3c9e370.tar.gz
nixlib-bc3c074cb858cf82cde42212ebf66b06d3c9e370.tar.bz2
nixlib-bc3c074cb858cf82cde42212ebf66b06d3c9e370.tar.lz
nixlib-bc3c074cb858cf82cde42212ebf66b06d3c9e370.tar.xz
nixlib-bc3c074cb858cf82cde42212ebf66b06d3c9e370.tar.zst
nixlib-bc3c074cb858cf82cde42212ebf66b06d3c9e370.zip
Added unbound, RepLib, type-equality.
svn path=/nixpkgs/trunk/; revision=29148
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/libraries/haskell/RepLib/default.nix19
-rw-r--r--pkgs/development/libraries/haskell/type-equality/default.nix18
-rw-r--r--pkgs/development/libraries/haskell/unbound/default.nix19
3 files changed, 56 insertions, 0 deletions
diff --git a/pkgs/development/libraries/haskell/RepLib/default.nix b/pkgs/development/libraries/haskell/RepLib/default.nix
new file mode 100644
index 000000000000..908ff5b62a99
--- /dev/null
+++ b/pkgs/development/libraries/haskell/RepLib/default.nix
@@ -0,0 +1,19 @@
+{ cabal, mtl, typeEquality }:
+
+cabal.mkDerivation (self: {
+  pname = "RepLib";
+  version = "0.5.1";
+  sha256 = "1c6zqi87lmmmiz8amsvhw6wkhg90rhh6yl5vh0a9ism3apwh1i7r";
+  buildDepends = [ mtl typeEquality ];
+  noHaddock = true;
+  meta = {
+    homepage = "http://code.google.com/p/replib/";
+    description = "Generic programming library with representation types";
+    license = self.stdenv.lib.licenses.bsd3;
+    platforms = self.ghc.meta.platforms;
+    maintainers = [
+      self.stdenv.lib.maintainers.andres
+      self.stdenv.lib.maintainers.simons
+    ];
+  };
+})
diff --git a/pkgs/development/libraries/haskell/type-equality/default.nix b/pkgs/development/libraries/haskell/type-equality/default.nix
new file mode 100644
index 000000000000..922f7bbd62f4
--- /dev/null
+++ b/pkgs/development/libraries/haskell/type-equality/default.nix
@@ -0,0 +1,18 @@
+{ cabal }:
+
+cabal.mkDerivation (self: {
+  pname = "type-equality";
+  version = "0.1.0.2";
+  sha256 = "09m6vc5hglf3xdg0bg9lgbkgjffmbkfgcrqf5ii36l92c4dik32q";
+  noHaddock = true;
+  meta = {
+    homepage = "http://github.com/hesselink/type-equality/";
+    description = "Type equality, coercion/cast and other operations";
+    license = self.stdenv.lib.licenses.bsd3;
+    platforms = self.ghc.meta.platforms;
+    maintainers = [
+      self.stdenv.lib.maintainers.andres
+      self.stdenv.lib.maintainers.simons
+    ];
+  };
+})
diff --git a/pkgs/development/libraries/haskell/unbound/default.nix b/pkgs/development/libraries/haskell/unbound/default.nix
new file mode 100644
index 000000000000..e58da04d0391
--- /dev/null
+++ b/pkgs/development/libraries/haskell/unbound/default.nix
@@ -0,0 +1,19 @@
+{ cabal, mtl, RepLib, transformers }:
+
+cabal.mkDerivation (self: {
+  pname = "unbound";
+  version = "0.3.1";
+  sha256 = "13k53dcap8knvl2qzcykx838laas34xfc0480705vzl1z9z1xppz";
+  buildDepends = [ mtl RepLib transformers ];
+  noHaddock = true;
+  meta = {
+    homepage = "http://code.google.com/p/replib/";
+    description = "Generic support for programming with names and binders";
+    license = self.stdenv.lib.licenses.bsd3;
+    platforms = self.ghc.meta.platforms;
+    maintainers = [
+      self.stdenv.lib.maintainers.andres
+      self.stdenv.lib.maintainers.simons
+    ];
+  };
+})