about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorsternenseemann <sternenseemann@systemli.org>2024-03-13 13:25:12 +0100
committersternenseemann <sternenseemann@systemli.org>2024-03-13 13:25:12 +0100
commitbc1d6b30af6c7dbe1402645cf2c68b321555a8e3 (patch)
treefd4eacf018f416f81c4219dc9f9f8bf588690520 /pkgs/development
parent9e0e89d13cf3949328af8ca0e353c9e684695f54 (diff)
downloadnixlib-bc1d6b30af6c7dbe1402645cf2c68b321555a8e3.tar
nixlib-bc1d6b30af6c7dbe1402645cf2c68b321555a8e3.tar.gz
nixlib-bc1d6b30af6c7dbe1402645cf2c68b321555a8e3.tar.bz2
nixlib-bc1d6b30af6c7dbe1402645cf2c68b321555a8e3.tar.lz
nixlib-bc1d6b30af6c7dbe1402645cf2c68b321555a8e3.tar.xz
nixlib-bc1d6b30af6c7dbe1402645cf2c68b321555a8e3.tar.zst
nixlib-bc1d6b30af6c7dbe1402645cf2c68b321555a8e3.zip
haskellPackages.hw-fingertree: unify overrides
The test suite problem is universal. The workaround for it also alleviates the problem with GHC 9.8
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/haskell-modules/configuration-common.nix4
-rw-r--r--pkgs/development/haskell-modules/configuration-ghc-9.4.x.nix3
-rw-r--r--pkgs/development/haskell-modules/configuration-ghc-9.6.x.nix1
-rw-r--r--pkgs/development/haskell-modules/configuration-ghc-9.8.x.nix1
4 files changed, 4 insertions, 5 deletions
diff --git a/pkgs/development/haskell-modules/configuration-common.nix b/pkgs/development/haskell-modules/configuration-common.nix
index 986c71780830..2edd95c8536d 100644
--- a/pkgs/development/haskell-modules/configuration-common.nix
+++ b/pkgs/development/haskell-modules/configuration-common.nix
@@ -311,6 +311,10 @@ self: super: {
     })
   ]) super.memory;
 
+  # Depends on outdated deps hedgehog < 1.4, doctest < 0.12 for tests
+  # As well as deepseq < 1.5 (so it forbids GHC 9.8)
+  hw-fingertree = doJailbreak super.hw-fingertree;
+
   # 2024-03-10: Maintainance stalled, fixes unmerged: https://github.com/haskell/ThreadScope/pull/130
   threadscope = overrideCabal (drv: {
     prePatch = drv.prePatch or "" + ''
diff --git a/pkgs/development/haskell-modules/configuration-ghc-9.4.x.nix b/pkgs/development/haskell-modules/configuration-ghc-9.4.x.nix
index 3f63abcabe19..653187007b31 100644
--- a/pkgs/development/haskell-modules/configuration-ghc-9.4.x.nix
+++ b/pkgs/development/haskell-modules/configuration-ghc-9.4.x.nix
@@ -105,9 +105,6 @@ in {
   # Broken because of unix >= 2.8 for GHC >= 9.6
   darcs = unmarkBroken (doDistribute super.darcs);
 
-  # Test suite has too strict dependencies
-  hw-fingertree = dontCheck super.hw-fingertree;
-
   inherit
     (
       let
diff --git a/pkgs/development/haskell-modules/configuration-ghc-9.6.x.nix b/pkgs/development/haskell-modules/configuration-ghc-9.6.x.nix
index 726ced3e65d4..e46a36dea4bc 100644
--- a/pkgs/development/haskell-modules/configuration-ghc-9.6.x.nix
+++ b/pkgs/development/haskell-modules/configuration-ghc-9.6.x.nix
@@ -109,7 +109,6 @@ self: super: {
   servant-lucid = doJailbreak super.servant-lucid;
 
   lifted-base = dontCheck super.lifted-base;
-  hw-fingertree = dontCheck super.hw-fingertree;
   hw-prim = dontCheck (doJailbreak super.hw-prim);
   stm-containers = dontCheck super.stm-containers;
   regex-tdfa = dontCheck super.regex-tdfa;
diff --git a/pkgs/development/haskell-modules/configuration-ghc-9.8.x.nix b/pkgs/development/haskell-modules/configuration-ghc-9.8.x.nix
index 56ca1ae601fc..5613f36b0c95 100644
--- a/pkgs/development/haskell-modules/configuration-ghc-9.8.x.nix
+++ b/pkgs/development/haskell-modules/configuration-ghc-9.8.x.nix
@@ -94,7 +94,6 @@ self: super: {
   statestack = doJailbreak super.statestack; # base < 4.19
   newtype-generics = doJailbreak super.newtype-generics; # base < 4.19
   hw-prim = doJailbreak super.hw-prim; # doctest < 0.22, ghc-prim < 0.11, hedgehog < 1.4
-  hw-fingertree = doJailbreak super.hw-fingertree; # deepseq <1.5, doctest < 0.22, hedgehog < 1.4
   svg-builder = doJailbreak super.svg-builder; # base <4.19, bytestring <0.12, text <2.1
   # Too strict bound on base, believe it or not.
   # https://github.com/judah/terminfo/pull/55#issuecomment-1876894232