about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorPeter Simons <simons@cryp.to>2016-06-21 11:54:14 +0200
committerGitHub <noreply@github.com>2016-06-21 11:54:14 +0200
commitbc08bef615261dff66ddc0384398fd8565c778cf (patch)
tree5a3902e13fc99f1565ed0ac60f370f77e4056d1e /pkgs/development
parente945646be3a045948801ff7262bec11a7b9315b3 (diff)
parent7cbf4a56f7f6f281570692403e79f89cc21ae388 (diff)
downloadnixlib-bc08bef615261dff66ddc0384398fd8565c778cf.tar
nixlib-bc08bef615261dff66ddc0384398fd8565c778cf.tar.gz
nixlib-bc08bef615261dff66ddc0384398fd8565c778cf.tar.bz2
nixlib-bc08bef615261dff66ddc0384398fd8565c778cf.tar.lz
nixlib-bc08bef615261dff66ddc0384398fd8565c778cf.tar.xz
nixlib-bc08bef615261dff66ddc0384398fd8565c778cf.tar.zst
nixlib-bc08bef615261dff66ddc0384398fd8565c778cf.zip
Merge pull request #16382 from Ericson2314/morgue
Remove misc dead code
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/compilers/ghc/with-packages.nix70
1 files changed, 0 insertions, 70 deletions
diff --git a/pkgs/development/compilers/ghc/with-packages.nix b/pkgs/development/compilers/ghc/with-packages.nix
deleted file mode 100644
index 9909c49e1435..000000000000
--- a/pkgs/development/compilers/ghc/with-packages.nix
+++ /dev/null
@@ -1,70 +0,0 @@
-{ stdenv, ghc, packages, buildEnv, makeWrapper, ignoreCollisions ? false }:
-
-# This wrapper works only with GHC 6.12 or later.
-assert stdenv.lib.versionOlder "6.12" ghc.version;
-
-# It's probably a good idea to include the library "ghc-paths" in the
-# compiler environment, because we have a specially patched version of
-# that package in Nix that honors these environment variables
-#
-#   NIX_GHC
-#   NIX_GHCPKG
-#   NIX_GHC_DOCDIR
-#   NIX_GHC_LIBDIR
-#
-# instead of hard-coding the paths. The wrapper sets these variables
-# appropriately to configure ghc-paths to point back to the wrapper
-# instead of to the pristine GHC package, which doesn't know any of the
-# additional libraries.
-#
-# A good way to import the environment set by the wrapper below into
-# your shell is to add the following snippet to your ~/.bashrc:
-#
-#   if [ -e ~/.nix-profile/bin/ghc ]; then
-#     eval $(grep export ~/.nix-profile/bin/ghc)
-#   fi
-
-let
-  ghc761OrLater = stdenv.lib.versionOlder "7.6.1" ghc.version;
-  packageDBFlag = if ghc761OrLater then "--global-package-db" else "--global-conf";
-  libDir        = "$out/lib/ghc-${ghc.version}";
-  docDir        = "$out/share/doc/ghc/html";
-  packageCfgDir = "${libDir}/package.conf.d";
-  isHaskellPkg  = x: (x ? pname) && (x ? version);
-in
-if packages == [] then ghc else
-buildEnv {
-  name = "haskell-env-${ghc.name}";
-  paths = stdenv.lib.filter isHaskellPkg (stdenv.lib.closePropagation packages) ++ [ghc];
-  inherit ignoreCollisions;
-  postBuild = ''
-    . ${makeWrapper}/nix-support/setup-hook
-
-    for prg in ghc ghci ghc-${ghc.version} ghci-${ghc.version}; do
-      rm -f $out/bin/$prg
-      makeWrapper ${ghc}/bin/$prg $out/bin/$prg         \
-        --add-flags '"-B$NIX_GHC_LIBDIR"'               \
-        --set "NIX_GHC"        "$out/bin/ghc"           \
-        --set "NIX_GHCPKG"     "$out/bin/ghc-pkg"       \
-        --set "NIX_GHC_DOCDIR" "${docDir}"              \
-        --set "NIX_GHC_LIBDIR" "${libDir}"
-    done
-
-    for prg in runghc runhaskell; do
-      rm -f $out/bin/$prg
-      makeWrapper ${ghc}/bin/$prg $out/bin/$prg         \
-        --add-flags "-f $out/bin/ghc"                   \
-        --set "NIX_GHC"        "$out/bin/ghc"           \
-        --set "NIX_GHCPKG"     "$out/bin/ghc-pkg"       \
-        --set "NIX_GHC_DOCDIR" "${docDir}"              \
-        --set "NIX_GHC_LIBDIR" "${libDir}"
-    done
-
-    for prg in ghc-pkg ghc-pkg-${ghc.version}; do
-      rm -f $out/bin/$prg
-      makeWrapper ${ghc}/bin/$prg $out/bin/$prg --add-flags "${packageDBFlag}=${packageCfgDir}"
-    done
-
-    $out/bin/ghc-pkg recache
-  '';
-}