about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authortoastal <toastal@posteo.net>2023-06-04 13:37:00 +0700
committertoastal <toastal@posteo.net>2023-06-13 13:17:47 +0700
commitb81b9b0df913cee1ffffd99d09ea19258813518e (patch)
treef8a4d7e5182f0a261a71024d0c4058274ec74e68 /pkgs/development
parentbf7e951996bc9d6ad734e5670e2a517dfdbaa7b1 (diff)
downloadnixlib-b81b9b0df913cee1ffffd99d09ea19258813518e.tar
nixlib-b81b9b0df913cee1ffffd99d09ea19258813518e.tar.gz
nixlib-b81b9b0df913cee1ffffd99d09ea19258813518e.tar.bz2
nixlib-b81b9b0df913cee1ffffd99d09ea19258813518e.tar.lz
nixlib-b81b9b0df913cee1ffffd99d09ea19258813518e.tar.xz
nixlib-b81b9b0df913cee1ffffd99d09ea19258813518e.tar.zst
nixlib-b81b9b0df913cee1ffffd99d09ea19258813518e.zip
ocamlPacakges.domain-local-await: init at 0.2.0
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/ocaml-modules/domain-local-await/default.nix34
1 files changed, 34 insertions, 0 deletions
diff --git a/pkgs/development/ocaml-modules/domain-local-await/default.nix b/pkgs/development/ocaml-modules/domain-local-await/default.nix
new file mode 100644
index 000000000000..b5c4c980f063
--- /dev/null
+++ b/pkgs/development/ocaml-modules/domain-local-await/default.nix
@@ -0,0 +1,34 @@
+{ lib
+, buildDunePackage
+, fetchurl
+, mdx
+}:
+
+buildDunePackage rec {
+  pname = "domain-local-await";
+  version = "0.2.0";
+
+  minimalOCamlVersion = "5.0";
+  duneVersion = "3";
+
+  src = fetchurl {
+    url = "https://github.com/ocaml-multicore/${pname}/releases/download/${version}/${pname}-${version}.tbz";
+    sha256 = "2DCJsI3nGPtbXnU8jRvzR1iNAkNuekVy4Lid1qnHXDo=";
+  };
+
+  checkInputs = [
+    mdx
+  ];
+
+  nativeCheckInputs = [
+    mdx.bin
+  ];
+
+  meta = {
+    homepage = "https://github.com/ocaml-multicore/ocaml-${pname}";
+    changelog = "https://github.com/ocaml-multicore/ocaml-${pname}/raw/v${version}/CHANGES.md";
+    description = "A scheduler independent blocking mechanism";
+    license = with lib.licenses; [ bsd0 ];
+    maintainers = with lib.maintainers; [ toastal ];
+  };
+}