about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
author(cdep)illabout <cdep.illabout@gmail.com>2020-02-11 10:52:47 +0900
committerPeter Simons <simons@cryp.to>2020-02-28 20:31:21 +0100
commitb6f45d056a8dbce4303f93dd158c6b0b6416ca3c (patch)
tree1a901d4d48cb67eab3181ad8152eeb7e2f217133 /pkgs/development
parentb68c9dda98a2d108464e1e142b0e53ae97df79b5 (diff)
downloadnixlib-b6f45d056a8dbce4303f93dd158c6b0b6416ca3c.tar
nixlib-b6f45d056a8dbce4303f93dd158c6b0b6416ca3c.tar.gz
nixlib-b6f45d056a8dbce4303f93dd158c6b0b6416ca3c.tar.bz2
nixlib-b6f45d056a8dbce4303f93dd158c6b0b6416ca3c.tar.lz
nixlib-b6f45d056a8dbce4303f93dd158c6b0b6416ca3c.tar.xz
nixlib-b6f45d056a8dbce4303f93dd158c6b0b6416ca3c.tar.zst
nixlib-b6f45d056a8dbce4303f93dd158c6b0b6416ca3c.zip
haskellPackages.cabal-plan: fix up ansi-terminal dep
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/haskell-modules/configuration-common.nix8
-rw-r--r--pkgs/development/haskell-modules/configuration-hackage2nix.yaml1
2 files changed, 8 insertions, 1 deletions
diff --git a/pkgs/development/haskell-modules/configuration-common.nix b/pkgs/development/haskell-modules/configuration-common.nix
index 723db5ab2794..d21ebe11fea5 100644
--- a/pkgs/development/haskell-modules/configuration-common.nix
+++ b/pkgs/development/haskell-modules/configuration-common.nix
@@ -1254,7 +1254,13 @@ self: super: {
   });
 
   # The LTS-14.x version of their dependencies are too old.
-  cabal-plan = super.cabal-plan.overrideScope (self: super: { optparse-applicative = self.optparse-applicative_0_15_1_0; ansi-terminal = self.ansi-terminal_0_10_2; base-compat = self.base-compat_0_11_1; semialign = self.semialign_1_1; time-compat = doJailbreak super.time-compat; });
+  cabal-plan = super.cabal-plan.overrideScope (self: super: {
+    optparse-applicative = self.optparse-applicative_0_15_1_0;
+    ansi-terminal = self.ansi-terminal_0_10_3;
+    base-compat = self.base-compat_0_11_1;
+    semialign = self.semialign_1_1;
+    time-compat = doJailbreak super.time-compat;
+  });
   hoogle = super.hoogle.override { haskell-src-exts = self.haskell-src-exts_1_23_0; };
 
   # Version bounds for http-client are too strict:
diff --git a/pkgs/development/haskell-modules/configuration-hackage2nix.yaml b/pkgs/development/haskell-modules/configuration-hackage2nix.yaml
index 18db76ca3cf4..31c7d2b8a76a 100644
--- a/pkgs/development/haskell-modules/configuration-hackage2nix.yaml
+++ b/pkgs/development/haskell-modules/configuration-hackage2nix.yaml
@@ -2341,6 +2341,7 @@ default-package-overrides:
 
 extra-packages:
   - aeson < 0.8                         # newer versions don't work with GHC 7.6.x or earlier
+  - ansi-terminal == 0.10.3             # required by cabal-plan, and policeman in ghc-8.8.x
   - aeson-pretty < 0.8                  # required by elm compiler
   - apply-refact < 0.4                  # newer versions don't work with GHC 8.0.x
   - aws ^>= 0.18                        # pre-lts-11.x versions neeed by git-annex 6.20180227