about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorFabian Affolter <mail@fabian-affolter.ch>2024-03-26 11:24:22 +0100
committerGitHub <noreply@github.com>2024-03-26 11:24:22 +0100
commitb6dfa1ce7cc5d1b75f290a7972da4f31232aca9a (patch)
treea8fd9365f376b2e64367e2c417a703c904c2a096 /pkgs/development
parent3bd94e764eb93ccdf8356298e03b85ea2980ef2e (diff)
downloadnixlib-b6dfa1ce7cc5d1b75f290a7972da4f31232aca9a.tar
nixlib-b6dfa1ce7cc5d1b75f290a7972da4f31232aca9a.tar.gz
nixlib-b6dfa1ce7cc5d1b75f290a7972da4f31232aca9a.tar.bz2
nixlib-b6dfa1ce7cc5d1b75f290a7972da4f31232aca9a.tar.lz
nixlib-b6dfa1ce7cc5d1b75f290a7972da4f31232aca9a.tar.xz
nixlib-b6dfa1ce7cc5d1b75f290a7972da4f31232aca9a.tar.zst
nixlib-b6dfa1ce7cc5d1b75f290a7972da4f31232aca9a.zip
python312Packages.pipdeptree: refactor
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/python-modules/pipdeptree/default.nix6
1 files changed, 3 insertions, 3 deletions
diff --git a/pkgs/development/python-modules/pipdeptree/default.nix b/pkgs/development/python-modules/pipdeptree/default.nix
index 67cfd7abaa18..a7b132c23088 100644
--- a/pkgs/development/python-modules/pipdeptree/default.nix
+++ b/pkgs/development/python-modules/pipdeptree/default.nix
@@ -15,7 +15,7 @@
 buildPythonPackage rec {
   pname = "pipdeptree";
   version = "2.16.2";
-  format = "pyproject";
+  pyproject = true;
 
   disabled = pythonOlder "3.8";
 
@@ -26,12 +26,12 @@ buildPythonPackage rec {
     hash = "sha256-g0O0ndHd2ehBUmHwb0HoWgCGSsqbjmlPFOd6KrkUv2Y=";
   };
 
-  nativeBuildInputs = [
+  build-system = [
     hatchling
     hatch-vcs
   ];
 
-  propagatedBuildInputs = [
+  dependencies = [
     pip
   ];