about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorFrederik Rietdijk <fridh@fridh.nl>2017-12-30 12:58:00 +0100
committerFrederik Rietdijk <fridh@fridh.nl>2017-12-31 11:01:53 +0100
commitb4dda635909dfee893c2aa48f120d2c8f9a74155 (patch)
tree50f3faf388e2f38ce2fdeaa2a0e2511cc4d7d68a /pkgs/development
parente21ac0ceae85b43ab2a02fd926755531e3b135cf (diff)
downloadnixlib-b4dda635909dfee893c2aa48f120d2c8f9a74155.tar
nixlib-b4dda635909dfee893c2aa48f120d2c8f9a74155.tar.gz
nixlib-b4dda635909dfee893c2aa48f120d2c8f9a74155.tar.bz2
nixlib-b4dda635909dfee893c2aa48f120d2c8f9a74155.tar.lz
nixlib-b4dda635909dfee893c2aa48f120d2c8f9a74155.tar.xz
nixlib-b4dda635909dfee893c2aa48f120d2c8f9a74155.tar.zst
nixlib-b4dda635909dfee893c2aa48f120d2c8f9a74155.zip
python.pkgs.attrs: disable tests to prevent infinite recursion
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/python-modules/attrs/default.nix6
1 files changed, 4 insertions, 2 deletions
diff --git a/pkgs/development/python-modules/attrs/default.nix b/pkgs/development/python-modules/attrs/default.nix
index c67ad6ece881..8ef2b5989f45 100644
--- a/pkgs/development/python-modules/attrs/default.nix
+++ b/pkgs/development/python-modules/attrs/default.nix
@@ -2,7 +2,6 @@
 , pympler, coverage, six, clang }:
 
 buildPythonPackage rec {
-  name = "${pname}-${version}";
   pname = "attrs";
   version = "17.4.0";
 
@@ -12,7 +11,7 @@ buildPythonPackage rec {
   };
 
   # macOS needs clang for testing
-  buildInputs = [
+  checkInputs = [
     pytest hypothesis zope_interface pympler coverage six
   ] ++ lib.optionals (stdenv.isDarwin) [ clang ];
 
@@ -20,6 +19,9 @@ buildPythonPackage rec {
     py.test
   '';
 
+  # To prevent infinite recursion with pytest
+  doCheck = false;
+
   meta = with lib; {
     description = "Python attributes without boilerplate";
     homepage = https://github.com/hynek/attrs;