about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorSpencer Baugh <sbaugh@catern.com>2017-12-28 17:56:52 +0000
committerSpencer Baugh <sbaugh@catern.com>2018-01-10 16:02:47 +0000
commitb2b00358e80ea6a0a9f24211411717e1bddd3bd7 (patch)
tree0dac431b09f66a5df5749bdadde24a27b20eca8a /pkgs/development
parent01bf384409618a6ece3d507c7222106657328c03 (diff)
downloadnixlib-b2b00358e80ea6a0a9f24211411717e1bddd3bd7.tar
nixlib-b2b00358e80ea6a0a9f24211411717e1bddd3bd7.tar.gz
nixlib-b2b00358e80ea6a0a9f24211411717e1bddd3bd7.tar.bz2
nixlib-b2b00358e80ea6a0a9f24211411717e1bddd3bd7.tar.lz
nixlib-b2b00358e80ea6a0a9f24211411717e1bddd3bd7.tar.xz
nixlib-b2b00358e80ea6a0a9f24211411717e1bddd3bd7.tar.zst
nixlib-b2b00358e80ea6a0a9f24211411717e1bddd3bd7.zip
pythonPackages.supervise_api: fix deps on Python 2
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/python-modules/supervise_api/default.nix8
1 files changed, 7 insertions, 1 deletions
diff --git a/pkgs/development/python-modules/supervise_api/default.nix b/pkgs/development/python-modules/supervise_api/default.nix
index 85f0106db65d..99c6dfaf9397 100644
--- a/pkgs/development/python-modules/supervise_api/default.nix
+++ b/pkgs/development/python-modules/supervise_api/default.nix
@@ -2,6 +2,8 @@
 , buildPythonPackage
 , fetchPypi
 , supervise
+, isPy3k
+, whichcraft
 }:
 
 buildPythonPackage rec {
@@ -15,7 +17,11 @@ buildPythonPackage rec {
     sha256 = "e6982633a924cb5192d2291d25b366ff311876a31b0f5961471b39d87397ef5b";
   };
 
-  propagatedBuildInputs = [ supervise ];
+  propagatedBuildInputs = [
+    supervise
+  ] ++ lib.optionals ( !isPy3k ) [
+    whichcraft
+  ];
 
   # no tests
   doCheck = false;