about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2010-03-01 17:08:25 +0000
committerLudovic Courtès <ludo@gnu.org>2010-03-01 17:08:25 +0000
commita86e0ad8aa335b1b878ffe3337df5c68399d0333 (patch)
treeee14dc980331491a5ab169a6fd30e3b2ad52de1f /pkgs/development
parent06944c9e136b1367ee1a896494ff0224b57bbc5e (diff)
downloadnixlib-a86e0ad8aa335b1b878ffe3337df5c68399d0333.tar
nixlib-a86e0ad8aa335b1b878ffe3337df5c68399d0333.tar.gz
nixlib-a86e0ad8aa335b1b878ffe3337df5c68399d0333.tar.bz2
nixlib-a86e0ad8aa335b1b878ffe3337df5c68399d0333.tar.lz
nixlib-a86e0ad8aa335b1b878ffe3337df5c68399d0333.tar.xz
nixlib-a86e0ad8aa335b1b878ffe3337df5c68399d0333.tar.zst
nixlib-a86e0ad8aa335b1b878ffe3337df5c68399d0333.zip
pyopengl: Move to `python-packages.nix'.
svn path=/nixpkgs/trunk/; revision=20317
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/python-modules/pyopengl/default.nix38
1 files changed, 0 insertions, 38 deletions
diff --git a/pkgs/development/python-modules/pyopengl/default.nix b/pkgs/development/python-modules/pyopengl/default.nix
deleted file mode 100644
index 6a8008d25255..000000000000
--- a/pkgs/development/python-modules/pyopengl/default.nix
+++ /dev/null
@@ -1,38 +0,0 @@
-{ fetchurl, stdenv, python, setuptools, mesa, freeglut, pil }:
-
-let version = "3.0.0b5";
-in
-  stdenv.mkDerivation {
-    name = "pyopengl-${version}";
-
-    src = fetchurl {
-      url = "mirror://sourceforge/pyopengl/PyOpenGL-${version}.tar.gz";
-      sha256 = "1rjpl2qdcqn4wamkik840mywdycd39q8dn3wqfaiv35jdsbifxx3";
-    };
-
-    # Note: We need `ctypes', available in Python 2.5+.
-    buildInputs = [ python ];
-    propagatedBuildInputs = [ setuptools mesa freeglut pil ];
-
-    configurePhase = "ensureDir $out/lib/python2.5/site-packages";
-    buildPhase     = "python setup.py build";
-
-    installPhase   = ''
-      PYTHONPATH="$out/lib/python2.5/site-packages:$PYTHONPATH" \
-      python setup.py install --prefix=$out
-    '';
-
-    meta = {
-      homepage = http://pyopengl.sourceforge.net/;
-      description = "PyOpenGL, the Python OpenGL bindings";
-
-      longDescription = ''
-        PyOpenGL is the cross platform Python binding to OpenGL and
-        related APIs.  The binding is created using the standard (in
-        Python 2.5) ctypes library, and is provided under an extremely
-        liberal BSD-style Open-Source license.
-      '';
-
-      license = "BSD-style";
-    };
-  }