about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorJason Felice <jason.m.felice@gmail.com>2020-01-03 23:05:16 -0500
committerFrederik Rietdijk <freddyrietdijk@fridh.nl>2020-01-06 19:23:24 +0100
commita54461f7a1bc28bb082d7fb9ce3f2c178f854c5d (patch)
tree891daa3926a3a01928bccfc2ba477cf8ae6cd476 /pkgs/development
parentde8700d42d6e266d96ce3458272222aed7a336f1 (diff)
downloadnixlib-a54461f7a1bc28bb082d7fb9ce3f2c178f854c5d.tar
nixlib-a54461f7a1bc28bb082d7fb9ce3f2c178f854c5d.tar.gz
nixlib-a54461f7a1bc28bb082d7fb9ce3f2c178f854c5d.tar.bz2
nixlib-a54461f7a1bc28bb082d7fb9ce3f2c178f854c5d.tar.lz
nixlib-a54461f7a1bc28bb082d7fb9ce3f2c178f854c5d.tar.xz
nixlib-a54461f7a1bc28bb082d7fb9ce3f2c178f854c5d.tar.zst
nixlib-a54461f7a1bc28bb082d7fb9ce3f2c178f854c5d.zip
graalvm8: use mercurial_4
Commit 88a473fc upgraded mercurial, made it use python3, and removed
support for hg-git, breaking graalvm8.  Since hg-git does not
officially support python3 or the new version of mercurial, this
patch uses mercurial_4.

Closes #76527.
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/compilers/graalvm/default.nix3
1 files changed, 2 insertions, 1 deletions
diff --git a/pkgs/development/compilers/graalvm/default.nix b/pkgs/development/compilers/graalvm/default.nix
index 438c899f5168..ec81063e67e2 100644
--- a/pkgs/development/compilers/graalvm/default.nix
+++ b/pkgs/development/compilers/graalvm/default.nix
@@ -1,10 +1,11 @@
-{ stdenv, lib, fetchFromGitHub, fetchurl, fetchzip, fetchgit, mercurial, python27, setJavaClassPath,
+{ stdenv, lib, fetchFromGitHub, fetchurl, fetchzip, fetchgit, mercurial_4, python27, setJavaClassPath,
   zlib, makeWrapper, openjdk, unzip, git, clang, llvm, which, icu, ruby, bzip2, glibc
   # gfortran, readline, bzip2, lzma, pcre, curl, ed, tree ## WIP: fastr deps
 }:
 
 let
   version = "19.1.1";
+  mercurial = mercurial_4;
   truffleMake = ./truffle.make;
   makeMxGitCache = list: out: ''
      mkdir ${out}